aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-05-19 11:43:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-19 22:31:34 +0100
commit5cb1e0ec46e4fde1c15aeb6812eaaece4840ac1c (patch)
treef44155de0dda0d60c4b96114914fab0870a3cfc4
parent879b2c5ee2ae39d6c1ae9d44ab243d8c7b7874b4 (diff)
downloadopenembedded-core-contrib-5cb1e0ec46e4fde1c15aeb6812eaaece4840ac1c.tar.gz
zip: update SRC_URI
The infozip FTP server appears to have been taken down, so change the SRC_URI to point at their SourceForge project. Also as the SRC_URI can't be generated from the version and there is no other user of the .inc, merge the .bb and .inc together. [ YOCTO #9655 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/zip/zip.inc27
-rw-r--r--meta/recipes-extended/zip/zip_3.0.bb40
2 files changed, 32 insertions, 35 deletions
diff --git a/meta/recipes-extended/zip/zip.inc b/meta/recipes-extended/zip/zip.inc
deleted file mode 100644
index 21985a4a08..0000000000
--- a/meta/recipes-extended/zip/zip.inc
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "Compressor/archiver for creating and modifying .zip files"
-HOMEPAGE = "http://www.info-zip.org"
-SECTION = "console/utils"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
-
-SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/zip${@d.getVar('PV',1).replace('.', '')}.tgz \
- file://fix-security-format.patch"
-
-EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
- 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
- 'BINFLAGS=0755' 'INSTALL_D=install -d'"
-
-do_compile() {
- oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
- sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
- oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
-}
-
-do_install() {
- oe_runmake -f unix/Makefile prefix=${D}${prefix} \
- BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
- install
-}
-
-BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/zip/zip_3.0.bb b/meta/recipes-extended/zip/zip_3.0.bb
index 383da4b89e..087423a045 100644
--- a/meta/recipes-extended/zip/zip_3.0.bb
+++ b/meta/recipes-extended/zip/zip_3.0.bb
@@ -1,18 +1,42 @@
-require zip.inc
+SUMMARY = "Compressor/archiver for creating and modifying .zip files"
+HOMEPAGE = "http://www.info-zip.org"
+SECTION = "console/utils"
-PR="r2"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
+
+PR = "r2"
-# zip-2.32 still uses directory name of zip-2.30
S = "${WORKDIR}/zip30"
+SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
+ file://fix-security-format.patch"
+
SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
-# exclude version 2.3.2 which triggers a false positive
-UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
-
# zip.inc sets CFLAGS, but what Makefile actually uses is
# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
# whatever we set.
-#
-EXTRA_OEMAKE_append = " 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}'"
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
+ 'CFLAGS=-I. -DUNIX ${CFLAGS}' \
+ 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
+ 'INSTALL=install' 'INSTALL_D=install -d' \
+ 'BINFLAGS=0755'"
+
+do_compile() {
+ oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
+ sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
+ oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
+}
+
+do_install() {
+ oe_runmake -f unix/Makefile prefix=${D}${prefix} \
+ BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
+ install
+}
+
+BBCLASSEXTEND = "native"
+
+# exclude version 2.3.2 which triggers a false positive
+UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"