aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-01-25 11:14:03 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-29 08:49:43 +0000
commit7bef6109927d143136afad79674dab12cf4552c8 (patch)
tree7cec46eef50e07cb8cbe7a601b83680f97902d9b
parent32b363c2ba91fde4f10e5fe2c898b2fc2702aa85 (diff)
downloadopenembedded-core-contrib-7bef6109927d143136afad79674dab12cf4552c8.tar.gz
lsb: update to 5.0
The LSB test packages had been updated to 5.0 in lsbtest. We also need to bump to version 5.0 for this recipe. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/lsb/lsb_5.0.bb (renamed from meta/recipes-extended/lsb/lsb_4.1.bb)7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_5.0.bb
index 07856108b0..df4812e4bc 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_5.0.bb
@@ -2,7 +2,6 @@ SUMMARY = "LSB support for OpenEmbedded"
SECTION = "console/utils"
HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
LICENSE = "GPLv2+"
-PR = "r2"
LSB_CORE = "lsb-core-${TARGET_ARCH}"
LSB_CORE_x86 = "lsb-core-ia32"
@@ -43,12 +42,12 @@ do_install() {
mkdir -p ${D}${base_libdir}
mkdir -p ${D}${sysconfdir}/lsb-release.d
- printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
+ printf "LSB_VERSION=\"core-5.0-noarch:" > ${D}${sysconfdir}/lsb-release
if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then
- printf "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release
+ printf "core-5.0-ia32" >> ${D}${sysconfdir}/lsb-release
else
- printf "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
+ printf "core-5.0-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
fi
echo "\"" >> ${D}${sysconfdir}/lsb-release
echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release