aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-04 11:56:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-18 13:17:17 +0100
commit2a12c159aae9877a05e0ba023de278cdca59ac45 (patch)
treef42033e607be18908ef64b18fcc8dd575f0c0be8
parentba119d836c0f4b20a39c92fa2e64abb0d5a55ad4 (diff)
downloadopenembedded-core-contrib-2a12c159aae9877a05e0ba023de278cdca59ac45.tar.gz
rpm: Ensure macros file doesn't reference HOSTTOOLS
Currently the file encodes full paths to various host tools in the HOSTTOOLS directory which is bad in native and target cases. We can simply use the versions from PATH quite safely in OE. (From OE-Core rev: be901200d94beaa35e1d05eb502b117b3b523609) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index f31932ef55..2310ee6b09 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -128,6 +128,10 @@ do_install_append_class-target() {
rm -rf ${D}/var
}
+do_install_append () {
+ sed -i -e 's:${HOSTTOOLS_DIR}/::g' ${D}/${libdir}/rpm/macros
+}
+
FILES_${PN} += "${libdir}/rpm-plugins/*.so \
"