aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-05-16 16:27:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-18 14:01:37 +0100
commit5da7a0ba47d39612b08b4f71518b8384a3058b3f (patch)
tree6d60a24bd37e4b66bfdedabd61be7a2704094caf
parentbb5718b631151cff840bcfa171ad4f8326c2132e (diff)
downloadopenembedded-core-contrib-5da7a0ba47d39612b08b4f71518b8384a3058b3f.tar.gz
opkg-utils: don't generate PN-dev and PN-staticdev
opkg-utils ends up in any opkg/rpm image with package management as it's the provider for update-alternatives. If dev-pkgs is enabled then opkg-utils-dev will get installed, which is empty but will subsequently pull python3-dev into the image (as opkg-utils-python depends on python3). As this can result in all of Python appearing in otherwise small images, don't generate these pointless packages. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 2460a26324..06710b596b 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -39,6 +39,10 @@ do_install_append_class-target() {
fi
}
+# These are empty and will pull python3-dev into images where it wouldn't
+# have been otherwise, so don't generate them.
+PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
+
PACKAGES =+ "update-alternatives-opkg"
FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"