aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-11 16:46:04 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-01 08:04:11 +0100
commit3e751bd05f7033b15e717fa4d56fefd915d2ea0c (patch)
tree67cc7d2ca61d6e2e5c8feadc5c017eaeff5bd2aa
parent72be3752a56d681672fb3e04413ff3cc59391150 (diff)
downloadopenembedded-core-contrib-3e751bd05f7033b15e717fa4d56fefd915d2ea0c.tar.gz
python3-nose: add a recipe
This is needed for updating piglit to use Python 3. Python 2 based recipe can be later moved to meta-oe. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-nose_1.3.7.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-nose_1.3.7.bb b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
new file mode 100644
index 0000000000..a45d2f228f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Extends Python unittest to make testing easier"
+DESCRIPTION = "nose extends the test loading and running features of unittest, \
+making it easier to write, find and run tests."
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI = "http://pypi.python.org/packages/source/n/nose/nose-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "4d3ad0ff07b61373d2cefc89c5d0b20b"
+SRC_URI[sha256sum] = "f1bffef9cbc82628f6e7d7b40d7e255aefaa1adb6a1b1d26c69a8b79e6208a98"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/nose/"
+UPSTREAM_CHECK_REGEX = "/nose/(?P<pver>(\d+[\.\-_]*)+)"
+
+S = "${WORKDIR}/nose-${PV}"
+
+inherit setuptools3
+
+RDEPENDS_${PN}_class-target = "\
+ python3-unittest \
+ "
+
+BBCLASSEXTEND = "native nativesdk"