summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Dirson <yann@blade-group.com>2020-10-09 18:20:30 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-10 13:37:44 +0100
commit914526868656fd279b13ba8e4d721d27cb2a8792 (patch)
treea7b334b11c65b397e6f58da07b31a3e1e302f554
parent252385bef9b226f32691b8513869ea3e41813b40 (diff)
downloadopenembedded-core-contrib-914526868656fd279b13ba8e4d721d27cb2a8792.tar.gz
rngd: fix --debug to also filter syslog() calls
Debug logs were only controlled by --debug flag while in --foreground mode. In --daemon mode (the default for us) /var/log/message got stuffed with details of entropy pool refilling, which is useless in production, and hamful when log rotation then gets rid of the more useful logs. This change makes the two modes consistently only produce debug logs when --debug is specified. Signed-off-by: Yann Dirson <yann@blade-group.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/rng-tools/rng-tools/0001-rngd-fix-debug-to-also-filter-syslog-calls.patch46
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_6.10.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-support/rng-tools/rng-tools/0001-rngd-fix-debug-to-also-filter-syslog-calls.patch b/meta/recipes-support/rng-tools/rng-tools/0001-rngd-fix-debug-to-also-filter-syslog-calls.patch
new file mode 100644
index 0000000000..0733378668
--- /dev/null
+++ b/meta/recipes-support/rng-tools/rng-tools/0001-rngd-fix-debug-to-also-filter-syslog-calls.patch
@@ -0,0 +1,46 @@
+From 213a869e8315ead2c739acfcbde712358a842dee Mon Sep 17 00:00:00 2001
+From: Yann Dirson <yann@blade-group.com>
+Date: Fri, 9 Oct 2020 15:12:26 +0200
+Subject: [PATCH] rngd: fix --debug to also filter syslog() calls
+
+Debug logs were only controlled by --debug flag while in --foreground
+mode. In --daemon mode /var/log/message got stuffed with details of
+entropy pool refilling, which is useless in production, and hamful
+when log rotation then gets rid of the more useful logs. This is
+especially true for embedded systems.
+
+This change makes the two modes consistently only produce debug logs when
+--debug is specified.
+
+Upstream-Status: Backport [213a869e8315ead2c739acfcbde712358a842dee]
+
+Signed-off-by: Yann Dirson <yann@blade-group.com>
+---
+ rngd.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/rngd.h b/rngd.h
+index 901b6f1..a79ea0f 100644
+--- a/rngd.h
++++ b/rngd.h
+@@ -166,13 +166,13 @@ extern bool quiet;
+ #define message(priority,fmt,args...) do { \
+ if (quiet) \
+ break;\
++ if (arguments->debug == false && LOG_PRI(priority) == LOG_DEBUG) \
++ break;\
+ if (am_daemon) { \
+ syslog((priority), fmt, ##args); \
+ } else if (!msg_squash) { \
+- if ((LOG_PRI(priority) != LOG_DEBUG) || (arguments->debug == true)) {\
+- fprintf(stderr, fmt, ##args); \
+- fflush(stderr); \
+- } \
++ fprintf(stderr, fmt, ##args); \
++ fflush(stderr); \
+ } \
+ } while (0)
+
+--
+2.28.0
+
diff --git a/meta/recipes-support/rng-tools/rng-tools_6.10.bb b/meta/recipes-support/rng-tools/rng-tools_6.10.bb
index 3f9720e406..40ec5ad671 100644
--- a/meta/recipes-support/rng-tools/rng-tools_6.10.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_6.10.bb
@@ -12,6 +12,7 @@ SRC_URI = "\
git://github.com/nhorman/rng-tools.git \
file://a4b6d9ce64f132e463b9091d0536913ddaf11516.patch \
file://dab16a5fd4efde8ef569b358e19b1fcbc7d0d938.patch \
+ file://0001-rngd-fix-debug-to-also-filter-syslog-calls.patch \
file://init \
file://default \
file://rngd.service \