aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPushpal Sidhu <psidhu@gateworks.com>2015-10-21 08:44:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-24 12:17:42 +0100
commit48a596fe8564d8bbc3b84dcc47dec8476e7da0d2 (patch)
treed9e42bbdd569371997ffea0ab3557a26f19e40b7
parentf9540f50ea661e260ec2b82436238cfb989e23c5 (diff)
downloadopenembedded-core-contrib-48a596fe8564d8bbc3b84dcc47dec8476e7da0d2.tar.gz
gnome-desktop: add xkeyboard-config dependency
gnome-desktop will fail during do_configure if xkeyboard-config had not already been built. Please see the following for the error: | configure: error: Package requirements (gdk-pixbuf-2.0 >= 2.21.3 | gtk+-3.0 >= 3.3.6 | glib-2.0 >= 2.38.0 | gio-2.0 >= 2.38.0 | gsettings-desktop-schemas >= 3.5.91 | xrandr >= 1.3 | xext >= 1.1 | xkeyboard-config | iso-codes) were not met: | | No package 'xkeyboard-config' found Add dependency of xkeyboard-config to this to resolve this issue. Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-gnome/gnome-desktop/gnome-desktop3_3.16.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gnome-desktop/gnome-desktop3_3.16.2.bb b/meta/recipes-gnome/gnome-desktop/gnome-desktop3_3.16.2.bb
index aa11fa28d9..3765697f2a 100644
--- a/meta/recipes-gnome/gnome-desktop/gnome-desktop3_3.16.2.bb
+++ b/meta/recipes-gnome/gnome-desktop/gnome-desktop3_3.16.2.bb
@@ -10,7 +10,7 @@ inherit gnome pkgconfig
SRC_URI[archive.md5sum] = "ab5bf4cc94ad63639f42adcc1542b1f0"
SRC_URI[archive.sha256sum] = "3a8f196b46eb9dbd3ba2afb8fb5fef6a8825539d449a02181311242e22227bd0"
-DEPENDS += "gsettings-desktop-schemas gconf libxrandr virtual/libx11 gtk+3 glib-2.0 gnome-doc-utils gnome-common startup-notification iso-codes"
+DEPENDS += "gsettings-desktop-schemas gconf libxrandr virtual/libx11 gtk+3 glib-2.0 gnome-doc-utils gnome-common startup-notification xkeyboard-config iso-codes"
inherit distro_features_check
REQUIRED_DISTRO_FEATURES = "x11"