summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-05-10 14:19:28 +0200
committerAndreas Oberritter <obi@opendreambox.org>2020-07-02 12:18:38 +0200
commitd4cad05e110edb08050823768c9a90b9006813c6 (patch)
tree1a7178a74a2165c92b4b9bb2d16112f85ca08ea2
parentc2cd25e9107e857b2419d2002b3c8922a3adb48a (diff)
downloadopenembedded-core-contrib-d4cad05e110edb08050823768c9a90b9006813c6.tar.gz
apt: optionally build and install manpages
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/apt/apt/nodoc.patch18
-rw-r--r--meta/recipes-devtools/apt/apt_1.2.31.bb16
2 files changed, 15 insertions, 19 deletions
diff --git a/meta/recipes-devtools/apt/apt/nodoc.patch b/meta/recipes-devtools/apt/apt/nodoc.patch
deleted file mode 100644
index 78cf53884a..0000000000
--- a/meta/recipes-devtools/apt/apt/nodoc.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Disable documentation
-
-Upstream-Status: Inappropriate [configuration]
-Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
-
-Index: apt-1.2.24/Makefile
-===================================================================
---- apt-1.2.24.orig/Makefile
-+++ apt-1.2.24/Makefile
-@@ -19,7 +19,7 @@ all headers library clean veryclean bina
- $(MAKE) -C cmdline $@
- $(MAKE) -C ftparchive $@
- $(MAKE) -C dselect $@
-- $(MAKE) -C doc $@
-+# $(MAKE) -C doc $@
- $(MAKE) -C po $@
- # FIXME: -C test has issue swith parallel builds, investigate!
- -$(MAKE) -C test $@
diff --git a/meta/recipes-devtools/apt/apt_1.2.31.bb b/meta/recipes-devtools/apt/apt_1.2.31.bb
index 4d17a0c5c1..dc9d8154d0 100644
--- a/meta/recipes-devtools/apt/apt_1.2.31.bb
+++ b/meta/recipes-devtools/apt/apt_1.2.31.bb
@@ -10,7 +10,6 @@ SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/${BPN}/${P
file://no-nls-dpkg.patch \
file://fix-gcc-4.6-null-not-defined.patch \
file://truncate-filename.patch \
- file://nodoc.patch \
file://disable-configure-in-makefile.patch \
file://disable-test.patch \
file://0001-environment.mak-musl-based-systems-can-generate-shar.patch \
@@ -35,12 +34,20 @@ AUTOTOOLS_AUXDIR = "${S}/buildlib"
EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
EXTRA_OECONF = "--disable-rpath"
+EXTRA_OEMAKE = "DOCBOOK2TEXT=cat"
+CACHED_CONFIGUREVARS = " \
+ ac_cv_path_DOT= \
+ ac_cv_path_DOXYGEN= \
+ ac_cv_path_PO4A= \
+ ac_cv_path_W3M= \
+"
PACKAGECONFIG ??= "lzma"
PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
PACKAGECONFIG[bz2] = "ac_cv_lib_bz2_BZ2_bzopen=yes,ac_cv_lib_bz2_BZ2_bzopen=no,bzip2"
PACKAGECONFIG[lz4] = "ac_cv_lib_lz4_LZ4F_createCompressionContext=yes,ac_cv_lib_lz4_LZ4F_createCompressionContext=no,lz4"
PACKAGECONFIG[opkg] = ",,,"
+PACKAGECONFIG[manpages] = ",ac_cv_path_XSLTPROC=,libxslt-native"
USE_NLS_class-native = "yes"
@@ -93,6 +100,13 @@ do_install () {
install -m 0755 ${S}/dselect/$f ${D}${libdir}/dpkg/methods/apt
done
+ if ${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'true', 'false', d)}; then
+ for i in 1 5 8; do
+ install -d ${D}${mandir}/man${i}
+ install -m 0644 ${S}/doc/en/*.${i} ${D}${mandir}/man${i}
+ done
+ fi
+
for d in apt.conf.d preferences.d sources.list.d trusted.gpg.d; do
install -d ${D}${sysconfdir}/apt/$d
done