aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2017-01-28 22:01:56 +0100
committerAndreas Oberritter <obi@opendreambox.org>2019-04-08 13:49:57 +0200
commit100dc341fa0b0defe0a2294d8a03bb1899f7e0c7 (patch)
tree1a95c76d5fb862a36bdbc0579be0835b09a8215e
parent92c7a0885627c5b81f2d9cb702a5b0e20803febe (diff)
downloadopenembedded-core-contrib-100dc341fa0b0defe0a2294d8a03bb1899f7e0c7.tar.gz
dpkg: disable logging in update-alternatives
It caused problems during do_rootfs. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/dpkg/dpkg/0007-update-alternatives-disable-logging.patch37
-rw-r--r--meta/recipes-devtools/dpkg/dpkg_1.18.10.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dpkg/dpkg/0007-update-alternatives-disable-logging.patch b/meta/recipes-devtools/dpkg/dpkg/0007-update-alternatives-disable-logging.patch
new file mode 100644
index 0000000000..d2b498817e
--- /dev/null
+++ b/meta/recipes-devtools/dpkg/dpkg/0007-update-alternatives-disable-logging.patch
@@ -0,0 +1,37 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+From ba9da25e1bc818a3cb3c98624ac9316ed9162aff Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@opendreambox.org>
+Date: Sat, 28 Jan 2017 21:54:20 +0100
+Subject: [PATCH] update-alternatives: disable logging
+
+By default, update-alternatives writes to /var/log/alternatives.log.
+This causes errors on rootfs creation since recipe-sysroots were enabled.
+
+Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
+---
+ utils/update-alternatives.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/utils/update-alternatives.c b/utils/update-alternatives.c
+index 2b49819..567490c 100644
+--- a/utils/update-alternatives.c
++++ b/utils/update-alternatives.c
+@@ -58,7 +58,7 @@ static const char *prog_path = "update-alternatives";
+
+ /* Action to perform */
+ static const char *action = NULL;
+-static const char *log_file = LOGDIR "/alternatives.log";
++static const char *log_file;
+ /* Skip alternatives properly configured in auto mode (for --config) */
+ static int opt_skip_auto = 0;
+ static int opt_verbose = 0;
+@@ -424,7 +424,7 @@ log_msg(const char *fmt, ...)
+ {
+ va_list args;
+
+- if (fh_log == NULL) {
++ if (fh_log == NULL && log_file != NULL) {
+ fh_log = fopen(log_file, "a");
+ if (fh_log == NULL && errno != EACCES)
+ syserr(_("cannot append to '%s'"), log_file);
diff --git a/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb b/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb
index ee058967b0..09f6b5a804 100644
--- a/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb
+++ b/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb
@@ -13,6 +13,7 @@ SRC_URI = "http://snapshot.debian.org/archive/debian/20160731T221931Z/pool/main/
file://0005-dpkg-compiler.m4-remove-Wvla.patch \
file://0006-add-musleabi-to-known-target-tripets.patch \
file://0007-dpkg-deb-build.c-Remove-usage-of-clamp-mtime-in-tar.patch \
+ file://0007-update-alternatives-disable-logging.patch \
"
SRC_URI_append_class-native = " file://glibc2.5-sync_file_range.patch "