aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-06-06 17:26:58 +0200
committerAndreas Oberritter <obi@opendreambox.org>2017-06-26 22:57:15 +0200
commitef90cc78a701cb7c45a74d8f88bccd04a864d246 (patch)
tree4070082fa21e0e35724a32ffcefddbf759daed1e
parent9a4cdb692d2716d6d793c6c0ffef974a97da5c52 (diff)
downloadopenembedded-core-contrib-ef90cc78a701cb7c45a74d8f88bccd04a864d246.tar.gz
nfs-utils: new packageconfig options: blkid, ipv6, libmount, nfsv4, nfsv41
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb
index 61c354afa9..a0566d1d52 100644
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb
@@ -7,8 +7,7 @@ SECTION = "console/network"
LICENSE = "MIT & GPLv2+ & BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
-# util-linux for libblkid
-DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3"
+DEPENDS = "libcap"
RDEPENDS_${PN} = "${PN}-client bash"
RRECOMMENDS_${PN} = "kernel-module-nfsd"
@@ -57,19 +56,21 @@ SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
# --enable-uuid is need for cross-compiling
EXTRA_OECONF = "--with-statduser=rpcuser \
--enable-mountconfig \
- --enable-libmount-mount \
- --disable-nfsv41 \
- --enable-uuid \
--disable-gss \
--disable-nfsdcltrack \
--with-statdpath=/var/lib/nfs/statd \
"
-PACKAGECONFIG ??= "tcp-wrappers ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'tirpc', '', d)}"
+PACKAGECONFIG ??= "tcp-wrappers ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6 tirpc', '', d)} blkid libmount nfsv4"
PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
PACKAGECONFIG[tirpc] = "--enable-tirpc,--disable-tirpc,libtirpc"
+PACKAGECONFIG[blkid] = "--enable-uuid,--disable-uuid,util-linux"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
+PACKAGECONFIG[libmount] = "--enable-libmount-mount,--disable-libmount-mount,util-linux"
+PACKAGECONFIG[nfsv4] = "--enable-nfsv4,--disable-nfsv4,libevent libnfsidmap keyutils sqlite3"
+PACKAGECONFIG[nfsv41] = "--enable-nfsv41,--disable-nfsv41,lvm2"
INHIBIT_AUTO_STAGE = "1"