aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-05-10 14:19:28 +0200
committerAndreas Oberritter <obi@opendreambox.org>2017-06-26 22:57:15 +0200
commita02e4ff6d097e7bda847ec73328f49d3ede038ba (patch)
tree16abd39d83674d1d2de8ef2b29ffeface310a388
parent1981df3f74388a6ffa22ac69c677ac18fff3a04a (diff)
downloadopenembedded-core-contrib-a02e4ff6d097e7bda847ec73328f49d3ede038ba.tar.gz
apt: optionally build and install manpages
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/apt/apt/nodoc.patch18
-rw-r--r--meta/recipes-devtools/apt/apt_1.0.10.1.bb16
2 files changed, 15 insertions, 19 deletions
diff --git a/meta/recipes-devtools/apt/apt/nodoc.patch b/meta/recipes-devtools/apt/apt/nodoc.patch
deleted file mode 100644
index 449e42df4a..0000000000
--- a/meta/recipes-devtools/apt/apt/nodoc.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Disable documentation
-
-Upstream-Status: Inappropriate [configuration]
-Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
-
-Index: apt-0.9.7.7/Makefile
-===================================================================
---- apt-0.9.7.7.orig/Makefile
-+++ apt-0.9.7.7/Makefile
-@@ -17,7 +17,7 @@ all headers library clean veryclean bina
- $(MAKE) -C cmdline $@
- $(MAKE) -C ftparchive $@
- $(MAKE) -C dselect $@
-- $(MAKE) -C doc $@
-+# $(MAKE) -C doc $@
- $(MAKE) -C po $@
- $(MAKE) -C test $@
-
diff --git a/meta/recipes-devtools/apt/apt_1.0.10.1.bb b/meta/recipes-devtools/apt/apt_1.0.10.1.bb
index 76b734bf5a..5337d6742f 100644
--- a/meta/recipes-devtools/apt/apt_1.0.10.1.bb
+++ b/meta/recipes-devtools/apt/apt_1.0.10.1.bb
@@ -10,7 +10,6 @@ SRC_URI = "http://snapshot.debian.org/archive/debian/20150805T094928Z/pool/main/
file://no-nls-dpkg.patch \
file://fix-gcc-4.6-null-not-defined.patch \
file://truncate-filename.patch \
- file://nodoc.patch \
file://disable-configure-in-makefile.patch \
file://disable-test.patch \
file://0001-environment.mak-musl-based-systems-can-generate-shar.patch \
@@ -29,11 +28,19 @@ UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/apt/"
inherit autotools gettext update-alternatives
EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
+EXTRA_OEMAKE = "DOCBOOK2TEXT=cat"
+CACHED_CONFIGUREVARS = " \
+ ac_cv_path_DOT= \
+ ac_cv_path_DOXYGEN= \
+ ac_cv_path_PO4A= \
+ ac_cv_path_W3M= \
+"
PACKAGECONFIG ??= "lzma"
PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
PACKAGECONFIG[bz2] = "ac_cv_lib_bz2_BZ2_bzopen=yes,ac_cv_lib_bz2_BZ2_bzopen=no,bzip2"
PACKAGECONFIG[opkg] = ",,,"
+PACKAGECONFIG[manpages] = ",ac_cv_path_XSLTPROC=,libxslt-native"
USE_NLS_class-native = "yes"
@@ -79,6 +86,13 @@ do_install () {
install -m 0755 ${S}/dselect/$f ${D}${libdir}/dpkg/methods/apt
done
+ if ${@bb.utils.contains('PACKAGECONFIG', 'manpages', 'true', 'false', d)}; then
+ for i in 1 5 8; do
+ install -d ${D}${mandir}/man${i}
+ install -m 0644 ${S}/doc/en/*.${i} ${D}${mandir}/man${i}
+ done
+ fi
+
for d in apt.conf.d preferences.d sources.list.d trusted.gpg.d; do
install -d ${D}${sysconfdir}/apt/$d
done