aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-10-29 21:42:39 -0700
committerAndreas Oberritter <obi@opendreambox.org>2014-03-04 23:34:51 +0100
commitd0e2bd00c846c6cff246356588896a288af104ad (patch)
treee0cfc7927b3be7c28541f86e773c0c47eeb2cd6e
parentd69d9ce51cd0f0dbc71aba73832f97637cac1651 (diff)
downloadopenembedded-core-contrib-d0e2bd00c846c6cff246356588896a288af104ad.tar.gz
elfutils-native: Update the patch to include the missing pieces needed for tests
In the last patch we missed similar update for test/line2addr.c which meant that the build still failed. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> (cherry picked from commit cb966afe86a5856d846fb0d4fb627cdce2ae0670) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/elfutils/elfutils/fix-build-gcc-4.8.patch21
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.148.bb2
2 files changed, 18 insertions, 5 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils/fix-build-gcc-4.8.patch b/meta/recipes-devtools/elfutils/elfutils/fix-build-gcc-4.8.patch
index a7c351941f..0e28690207 100644
--- a/meta/recipes-devtools/elfutils/elfutils/fix-build-gcc-4.8.patch
+++ b/meta/recipes-devtools/elfutils/elfutils/fix-build-gcc-4.8.patch
@@ -25,11 +25,11 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Upstream-Status: Inappropriate [Caused by an earlier patch]
-Index: elfutils-0.155/src/addr2line.c
+Index: elfutils-0.148/src/addr2line.c
===================================================================
---- elfutils-0.155.orig/src/addr2line.c
-+++ elfutils-0.155/src/addr2line.c
-@@ -447,10 +447,10 @@ handle_address (const char *string, Dwfl
+--- elfutils-0.148.orig/src/addr2line.c 2013-09-23 17:46:45.513586538 -0700
++++ elfutils-0.148/src/addr2line.c 2013-09-23 17:46:46.329586558 -0700
+@@ -447,10 +447,10 @@
bool parsed = false;
int i, j;
char *name = NULL;
@@ -42,3 +42,16 @@ Index: elfutils-0.155/src/addr2line.c
{
default:
break;
+Index: elfutils-0.148/tests/line2addr.c
+===================================================================
+--- elfutils-0.148.orig/tests/line2addr.c 2013-09-23 17:46:45.521586538 -0700
++++ elfutils-0.148/tests/line2addr.c 2013-09-23 17:46:46.329586558 -0700
+@@ -132,7 +132,7 @@
+ {
+ struct args a = { .arg = argv[cnt] };
+
+- switch (sscanf (a.arg, "%a[^:]:%d", &a.file, &a.line))
++ switch (sscanf (a.arg, "%m[^:]:%d", &a.file, &a.line))
+ {
+ default:
+ case 0:
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.148.bb b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
index 716021b58e..99f2227dc7 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3\
file://EXCEPTION;md5=570adcb0c1218ab57f2249c67d0ce417"
DEPENDS = "libtool bzip2 zlib"
-PR = "r10"
+PR = "r11"
SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2"