aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-08-15 14:26:55 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-18 09:27:13 +0100
commitc009297d44df98ba103ee267e40ffdbc837e411f (patch)
treeea9eba610a4e2a25350cd200c9766ce74c393759
parente5581343303f2cf8724019c3cbfb92a87045a7f1 (diff)
downloadopenembedded-core-contrib-c009297d44df98ba103ee267e40ffdbc837e411f.tar.gz
linux-yocto/4.1: netfilter: x_tables: fix stable backport
There was an issue with a netfilter backport in 4.1.28-stable. To address it, we backport the -stable fix: netfilter: x_tables: fix stable backport Stable-4.1 backport of mainline commit 364723410175 ("netfilter: x_tables: validate targets of jumps") doesn't handle correctly the fact that 4.1 kernel is missing commit 482cfc318559 ("netfilter: xtables: avoid percpu ruleset duplication") so that t->entries is still a per-cpu array in find_jump_target(). Use the same fix as e.g. stable-3.14 backport. Fixes: 8163327a3a92 ("netfilter: x_tables: validate targets of jumps") Signed-off-by: Michal Kubecek <mkubecek@suse.cz> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 4171062172..64111750f3 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "0b68498784da5defb7658675e37d9bc615cd4c50"
+SRCREV_machine ?= "5772feaf5827e42e1950a91d95b2fc3c1845b5c6"
SRCREV_meta ?= "0d6de63d4603b9cc3a4a68391bcb5156b9b0cf96"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 08b931ca9f..9eae2e1cba 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.28"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "44af900716206d4cae283aa74e92f4118720724a"
+SRCREV_machine ?= "f6ab3612272bb22bac371403121609c66c50cd45"
SRCREV_meta ?= "0d6de63d4603b9cc3a4a68391bcb5156b9b0cf96"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index ef3d000a2f..8ba0bea59c 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "460340f28dd4ed608fd66692bcbac0bb24fe4aaf"
-SRCREV_machine_qemuarm64 ?= "44af900716206d4cae283aa74e92f4118720724a"
-SRCREV_machine_qemumips ?= "0ff21b2a5e92defa32b7cb76d39980b63a2eb5ca"
-SRCREV_machine_qemuppc ?= "6bd2872ce7e397d285f7df00f4d0efac286e2401"
-SRCREV_machine_qemux86 ?= "44af900716206d4cae283aa74e92f4118720724a"
-SRCREV_machine_qemux86-64 ?= "44af900716206d4cae283aa74e92f4118720724a"
-SRCREV_machine_qemumips64 ?= "248861985b609d1cd24e8d23b7d15abfb31cbdc2"
-SRCREV_machine ?= "44af900716206d4cae283aa74e92f4118720724a"
+SRCREV_machine_qemuarm ?= "2f133a201f2bbde4ce33731d1596d5144360bf87"
+SRCREV_machine_qemuarm64 ?= "f6ab3612272bb22bac371403121609c66c50cd45"
+SRCREV_machine_qemumips ?= "d1cbc627631f706d19e8e4518bfc38b266f3fb9f"
+SRCREV_machine_qemuppc ?= "d1699ce26291a3e07113057ad7e235f7891e73fb"
+SRCREV_machine_qemux86 ?= "f6ab3612272bb22bac371403121609c66c50cd45"
+SRCREV_machine_qemux86-64 ?= "f6ab3612272bb22bac371403121609c66c50cd45"
+SRCREV_machine_qemumips64 ?= "725278e5cbc402139051032a7b2137f6707c46d6"
+SRCREV_machine ?= "f6ab3612272bb22bac371403121609c66c50cd45"
SRCREV_meta ?= "0d6de63d4603b9cc3a4a68391bcb5156b9b0cf96"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \