aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-02-26 06:48:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:41 +0000
commitb759afa08e339126c4e8b7e2aa87ed0c9f4b5d0d (patch)
treea217cbe130261e48a9a1e4eac648363150b2f0e6
parent375c26ce229cd9dc90b5e7c4b8e6d52d832b606e (diff)
downloadopenembedded-core-contrib-b759afa08e339126c4e8b7e2aa87ed0c9f4b5d0d.tar.gz
mesa: Fix build on musl
It assumes __GLIBC__ where it could actually check for linux and include non-glibc C library implementations like musl which provide __BYTE_ORDER macros as well when computing system endianness Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/mesa/files/replace_glibc_check_with_linux.patch17
-rw-r--r--meta/recipes-graphics/mesa/mesa_11.1.1.bb4
2 files changed, 20 insertions, 1 deletions
diff --git a/meta/recipes-graphics/mesa/files/replace_glibc_check_with_linux.patch b/meta/recipes-graphics/mesa/files/replace_glibc_check_with_linux.patch
new file mode 100644
index 0000000000..e4461ef177
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/replace_glibc_check_with_linux.patch
@@ -0,0 +1,17 @@
+endianness check is OS wide and not specific to libc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+Index: mesa-11.1.1/src/gallium/include/pipe/p_config.h
+===================================================================
+--- mesa-11.1.1.orig/src/gallium/include/pipe/p_config.h
++++ mesa-11.1.1/src/gallium/include/pipe/p_config.h
+@@ -130,7 +130,7 @@
+ * Endian detection.
+ */
+
+-#ifdef __GLIBC__
++#if defined(__linux__)
+ #include <endian.h>
+
+ #if __BYTE_ORDER == __LITTLE_ENDIAN
diff --git a/meta/recipes-graphics/mesa/mesa_11.1.1.bb b/meta/recipes-graphics/mesa/mesa_11.1.1.bb
index 5d73feb5fb..502afcfd8a 100644
--- a/meta/recipes-graphics/mesa/mesa_11.1.1.bb
+++ b/meta/recipes-graphics/mesa/mesa_11.1.1.bb
@@ -1,6 +1,8 @@
require ${BPN}.inc
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz"
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz \
+ file://replace_glibc_check_with_linux.patch \
+"
SRC_URI[md5sum] = "1043dfb907beecb2a761272455960427"
SRC_URI[sha256sum] = "64db074fc514136b5fb3890111f0d50604db52f0b1e94ba3fcb0fe8668a7fd20"