summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Pijanowski <maciej.pijanowski@3mdeb.com>2018-08-13 19:57:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 09:49:41 +0100
commita0c5332aefe75cf314e78284f578b17c51b8ab27 (patch)
tree3e11e17eaa0ef64e9aa95230ee54461df4729734
parentb713626dda68d4f03632da2ecbb1e073397e0c7a (diff)
downloadopenembedded-core-contrib-a0c5332aefe75cf314e78284f578b17c51b8ab27.tar.gz
machine configs: replace deprecated "SERIAL_CONSOLE"
SERIAL_CONSOLE was already deprecated in 2013, yet still some machine configuration files were using it. This patch replaces it with SERIAL_CONSOLES, which is the successor. The default value in systemd-serialgetty.bb can also be safely transitioned from SERIAL_CONSOLE to SERIAL_CONSOLES, as this recipe already uses SERIAL_CONSOLES within do_install(). The documentation seems to be already up do date. beaglebone-yocto.conf in the bsp-guide already uses SERIAL_CONSOLES. The ref-manual redirects from SERIAL_CONSOLE to SERIAL_CONSOLES. [YOCTO #12653] Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone-yocto.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/edgerouter.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf4
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
index faa4f1bd36..5cc2923903 100644
--- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
+++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -20,7 +20,7 @@ WKS_FILE ?= "beaglebone-yocto.wks"
IMAGE_INSTALL_append = " kernel-devicetree kernel-image-zimage"
do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"
-SERIAL_CONSOLE = "115200 ttyO0"
+SERIAL_CONSOLES = "115200;ttyO0"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "4.15%"
diff --git a/meta-yocto-bsp/conf/machine/edgerouter.conf b/meta-yocto-bsp/conf/machine/edgerouter.conf
index 61f2145fd5..a3eeebf2f6 100644
--- a/meta-yocto-bsp/conf/machine/edgerouter.conf
+++ b/meta-yocto-bsp/conf/machine/edgerouter.conf
@@ -13,7 +13,7 @@ KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "4.15%"
-SERIAL_CONSOLE = "115200 ttyS0"
+SERIAL_CONSOLES = "115200;ttyS0"
USE_VT ?= "0"
MACHINE_EXTRA_RRECOMMENDS = "kernel-modules"
diff --git a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
index eae8157eab..441987a78e 100644
--- a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
+++ b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
@@ -1,5 +1,5 @@
#@TYPE: Machine
-#@DESCRIPTION: Machine configuration for running
+#@DESCRIPTION: Machine configuration for running
TARGET_FPU = ""
@@ -10,7 +10,7 @@ KERNEL_IMAGETYPE = "uImage"
EXTRA_IMAGEDEPENDS += "u-boot"
UBOOT_MACHINE = "MPC8315ERDB_config"
-SERIAL_CONSOLE = "115200 ttyS0"
+SERIAL_CONSOLES = "115200;ttyS0"
MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"