summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-21 22:43:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-23 10:10:43 +0100
commit601d8e87a7c796bd9d91d1ffa090d3b1afcf2a2d (patch)
treefd188f25febbd882abbb38cf42ad7a842618cce3
parentc0ea23832a96352d8eeda5cebc9d37a22c5d5439 (diff)
downloadopenembedded-core-contrib-601d8e87a7c796bd9d91d1ffa090d3b1afcf2a2d.tar.gz
musl: Update to latest master
changelog [1] * aad50fcd fix regression in dl_iterate_phdr reporting of modules with no TLS * 0ea78a64 nscd: fall back gracefully on kernels without AF_UNIX support * 95a540e1 mallocng/aligned_alloc: check for malloc failure * 2c00f95c make epoll_[p]wait a cancellation point * 521b4d27 fix dl_iterate_phdr dlpi_tls_data reporting to match spec * 122002f0 remove no-longer-needed special case handling in popen * 8ef9d46f use internal malloc for posix_spawn file actions objects * cfdfd5ea don't fail to map library/executable with zero-length segment maps * e48e99c1 suppress isascii() macro for C++ * b129cd86 guard against compilers failing to handle setjmp specially by default * 3309e2d7 aarch64/bits/mman.h: add PROT_MTE from linux v5.10 * 44331150 aarch64/bits/hwcap.h: add HWCAP2_MTE from linux v5.10 * 42aa19a0 add aarch64/bits/mman.h with PROT_BTI from linux v5.8 * b7554b5e aarch64/bits/hwcap.h: add HWCAP2_BTI from linux v5.8 * 87b8f148 signal.h: add MTE specific SIGSEGV codes from linux v5.10 * 19239cde sys/prctl.h: add MTE related constants from linux v5.10 * 8b29f023 elf.h: add NT_ARM_TAGGED_ADDR_CTRL from linux v5.10 * d7210f0c sys/mman.h: add MAP_HUGE_16KB from linux v5.10 * a7456524 sys/mount.h: add MS_NOSYMFOLLOW from linux v5.10 * 54ca1cc7 sys/membarrier.h: add new constants from linux v5.10 * fd285f9d bits/syscall.h: add process_madvise from linux v5.10 * 49b6df3d fix error return value for cuserid * cc577d0e fix misuse of getpwuid_r in cuserid * a75283d7 cuserid: don't return truncated results * ef137da6 cuserid: support invocation with a null pointer argument [1] https://git.musl-libc.org/cgit/musl/log/\?qt\=range\&q\=e5d2823631bbfebacf48e1a34ed28f28d7cb2570..aad50fcd791e009961621ddfbe3d4c245fd689a3 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/musl/musl_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index e6f9e2441e..ef8bc2eec3 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@
require musl.inc
inherit linuxloader
-SRCREV = "e5d2823631bbfebacf48e1a34ed28f28d7cb2570"
+SRCREV = "aad50fcd791e009961621ddfbe3d4c245fd689a3"
BASEVER = "1.2.2"