aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Randle <william.c.randle@intel.com>2016-03-18 11:16:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 22:57:59 +0000
commitc2450e4fd01487aaf5bb37a4c70a5397650ba5f8 (patch)
treed4ad813e5749f1a16bbd4a4614c2148bf259b8bd
parent36d59255131f6d3f289d4f5dfcb58a9890996ffe (diff)
downloadopenembedded-core-contrib-c2450e4fd01487aaf5bb37a4c70a5397650ba5f8.tar.gz
grub: add -Wno-error=trampolines to native CFLAGS
(Resend as mailer munged previous submission. Also updated comments to indicate problem is not limited to gcc 5.3.0.) Adds -Wno-error=trampolines to native CFLAGS prevent multiple compile errors when using gentoo builf of gcc. [YOCTO #9201] Signed-off-by: Bill Randle <william.c.randle@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
index 4e80e1815e..dbc034ce54 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -35,6 +35,10 @@ EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
+# ldm.c:114:7: error: trampoline generated for nested function 'hook' [-Werror=trampolines]
+# and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
+CFLAGS_append_class-native = " -Wno-error=trampolines"
+
do_install_class-native() {
install -d ${D}${bindir}
install -m 755 grub-mkimage ${D}${bindir}