aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-11 09:28:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:53 +0000
commitdb75c6dda5b7768249178eac2a8d6e1fc95fbe0f (patch)
tree0f86875433e60cf5776f2f16d08bdbdd966a2135
parent31ee3460c3a0578ed36f3f5a940617ccb873c721 (diff)
downloadopenembedded-core-contrib-db75c6dda5b7768249178eac2a8d6e1fc95fbe0f.tar.gz
unfs3: Depend on libtirpc when building on musl
needs a rpc implementation Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb
index 7e9d659671..eba1139e59 100644
--- a/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb
+++ b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb
@@ -9,11 +9,9 @@ RECIPE_UPSTREAM_DATE = "Oct 08, 2015"
CHECK_DATE = "Dec 10, 2015"
DEPENDS = "flex-native bison-native flex"
+DEPENDS_append_libc-musl = " libtirpc "
DEPENDS_append_class-nativesdk += "flex-nativesdk"
-SRC_URI[md5sum] = "3687acc4ee992e536472365dd99712a7"
-SRC_URI[sha256sum] = "274b43ada9c6eea1da26eb7010d72889c5278984ba0b50dff4e093057d4d64f8"
-
MOD_PV = "497"
S = "${WORKDIR}/trunk"
SRC_URI = "svn://svn.code.sf.net/p/unfs3/code;module=trunk;rev=${MOD_PV};protocol=http \
@@ -25,10 +23,14 @@ SRC_URI = "svn://svn.code.sf.net/p/unfs3/code;module=trunk;rev=${MOD_PV};protoco
file://relative_max_socket_path_len.patch \
file://tcp_no_delay.patch \
"
+SRC_URI[md5sum] = "3687acc4ee992e536472365dd99712a7"
+SRC_URI[sha256sum] = "274b43ada9c6eea1da26eb7010d72889c5278984ba0b50dff4e093057d4d64f8"
+
BBCLASSEXTEND = "native nativesdk"
inherit autotools
EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
+CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
# Turn off these header detects else the inode search
# will walk entire file systems and this is a real problem