aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-05-09 13:30:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-16 14:08:18 +0100
commit58922a43f93f89dcf344394d8b1c84d82276b6a5 (patch)
tree850bfe4c2c02b7b473989d8e9e59b8442695fba2
parent9acb0de00bcb8e8904be18bb3aaf7fc678ac9726 (diff)
downloadopenembedded-core-contrib-58922a43f93f89dcf344394d8b1c84d82276b6a5.tar.gz
gcr: add missing dependency on xsltproc if introspection is enabled
gcr needs xsltproc at build time if GObject Introspection is enabled. Also, remove the explicit disabling of g-i and gtk-doc on x86-64 targets, this appears to work now. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-gnome/gcr/gcr_3.20.0.bb16
1 files changed, 2 insertions, 14 deletions
diff --git a/meta/recipes-gnome/gcr/gcr_3.20.0.bb b/meta/recipes-gnome/gcr/gcr_3.20.0.bb
index f31abced02..4450e155e6 100644
--- a/meta/recipes-gnome/gcr/gcr_3.20.0.bb
+++ b/meta/recipes-gnome/gcr/gcr_3.20.0.bb
@@ -5,7 +5,8 @@ BUGTRACKER = "https://bugzilla.gnome.org/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
-DEPENDS = "intltool-native gtk+3 p11-kit glib-2.0 libgcrypt"
+DEPENDS = "intltool-native gtk+3 p11-kit glib-2.0 libgcrypt \
+ ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
inherit autotools gnomebase gtk-icon-cache gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
# depends on gtk+3, but also x11 through gtk+-x11
@@ -23,16 +24,3 @@ FILES_${PN} += " \
# http://errors.yoctoproject.org/Errors/Details/20229/
ARM_INSTRUCTION_SET = "arm"
-
-# on x86-64 the introspection binary goes into
-# an infinite loop under qemu during compilation,
-# printing the following:
-#
-# gcrypt-Message: select() error: Bad address
-#
-# gcrypt-Message: select() error: Bad address
-#
-# gcrypt-Message: select() error: Bad address
-#
-# This will be investigated later.
-EXTRA_OECONF_append_x86-64 = " --disable-introspection --disable-gtk-doc"