aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSerhii Popovych <spopovyc@cisco.com>2017-03-29 18:02:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-30 09:58:59 +0100
commitdd162286921ccac4981e091de1df4c36d5cfbf5b (patch)
treedf59e6401db8d79544751624c96a8a4121708652
parentc187326afcf1e9d781c1bd0923e1362a6f50f613 (diff)
downloadopenembedded-core-contrib-dd162286921ccac4981e091de1df4c36d5cfbf5b.tar.gz
dnf: Use lnr to create relative symlinks
Make use of lnr while creating relative symlinks to enable builds on host with old ln that does not support -r option. Cc: XE-Linux <xe-linux-external@cisco.com> Signed-off-by: Serhii Popovych <spopovyc@cisco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/dnf/dnf_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_git.bb b/meta/recipes-devtools/dnf/dnf_git.bb
index b6b6ceaff1..1194928ac9 100644
--- a/meta/recipes-devtools/dnf/dnf_git.bb
+++ b/meta/recipes-devtools/dnf/dnf_git.bb
@@ -31,8 +31,8 @@ RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient py
# .spec file in dnf source tree does (and then Fedora and dnf documentation
# says that dnf binary is plain 'dnf').
do_install_append() {
- ln -s -r ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
- ln -s -r ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
+ lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
+ lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
}
# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in