aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-03-28 10:31:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-28 10:34:26 +0100
commitd68a86d87aa017dd0fecb0f626d22711efefcd3f (patch)
tree44909b07e2e396169ac9a4645e8dad647eb3da54
parent969d079a33a57f5a8f7af86d7bab04d35ab07584 (diff)
downloadopenembedded-core-contrib-d68a86d87aa017dd0fecb0f626d22711efefcd3f.tar.gz
dnf: remove systemd units in nativesdk builds
If the DISTRO_FEATURES contain systemd then the systemd class won't delete the units for us. Until the class is fixed to do this automatically, delete them explicitly. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/dnf/dnf_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_git.bb b/meta/recipes-devtools/dnf/dnf_git.bb
index 7d7f597e5a..b6b6ceaff1 100644
--- a/meta/recipes-devtools/dnf/dnf_git.bb
+++ b/meta/recipes-devtools/dnf/dnf_git.bb
@@ -42,6 +42,12 @@ do_install_append_class-native() {
RPM_NO_CHROOT_FOR_SCRIPTS=1
}
+# If the distro uses systemd then these won't be deleted by systemd.bbclass
+do_install_append_class-nativesdk() {
+ rm -rf ${D}/${systemd_unitdir}
+ rmdir --ignore-fail-on-non-empty ${D}${nonarch_base_libdir}
+}
+
SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
dnf-automatic-download.service dnf-automatic-download.timer \
dnf-automatic-install.service dnf-automatic-install.timer \