aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-03-20 16:13:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-21 22:43:03 +0000
commit052547561f3b2c13d357da87061716c6eb968fb9 (patch)
treebb754dac7816937a5ef600df5fbe0d309938a58d
parent6750ea8160edccb156cb2ab68548adfc1c789895 (diff)
downloadopenembedded-core-contrib-052547561f3b2c13d357da87061716c6eb968fb9.tar.gz
gpgme: Avoid requiring a host C++ compiler with C++11 support
Building the C++ bindings for native requires a host C++ compiler with C++11 support. Since these bindings are currently not needed, we can disable them and thus avoid increasing the requirement for the host C++ compiler. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.8.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.8.0.bb b/meta/recipes-support/gpgme/gpgme_1.8.0.bb
index d3e7880a47..2756ef815d 100644
--- a/meta/recipes-support/gpgme/gpgme_1.8.0.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.8.0.bb
@@ -34,7 +34,11 @@ PACKAGECONFIG[python3] = ",,python3 swig-native,"
# Supported: "cl cpp python python2 python3 qt"
# python says 'search and find python2 or python3'
-LANGUAGES ?= "cpp"
+# Building the C++ bindings for native requires a C++ compiler with C++11
+# support. Since these bindings are currently not needed, we can disable them.
+DEFAULT_LANGUAGES = ""
+DEFAULT_LANGUAGES_class-target = "cpp"
+LANGUAGES ?= "${DEFAULT_LANGUAGES}"
LANGUAGES .= "${@bb.utils.contains('PACKAGECONFIG', 'python2', ' python2', '', d)}"
LANGUAGES .= "${@bb.utils.contains('PACKAGECONFIG', 'python3', ' python3', '', d)}"