summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Wood <michael.g.wood@intel.com>2016-04-26 17:18:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-29 10:25:25 +0100
commitf08651a954358e9c6ce4d69de285e4cd9e1408ae (patch)
treecce07829ef34b2f13462e84d5a3b842f6c02a2ca
parentbc30d1b235b9ecacef5b2eaa851b9247d857f317 (diff)
downloadopenembedded-core-contrib-f08651a954358e9c6ce4d69de285e4cd9e1408ae.tar.gz
toaster: customrecipe Only show download icon or button if it's possible
If the based on recipe has not yet been checked out/cloned we cannot generate the custom image recipe file that uses it. So disable/remove the option to download it. [YOCTO #9425] Signed-off-by: Michael Wood <michael.g.wood@intel.com> Signed-off-by: Elliot Smith <elliot.smith@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/toaster/toastergui/tables.py4
-rw-r--r--lib/toaster/toastergui/templates/customrecipe.html13
2 files changed, 15 insertions, 2 deletions
diff --git a/lib/toaster/toastergui/tables.py b/lib/toaster/toastergui/tables.py
index 2cc2f4eb7b..d375da434f 100644
--- a/lib/toaster/toastergui/tables.py
+++ b/lib/toaster/toastergui/tables.py
@@ -508,10 +508,12 @@ class CustomImagesTable(ToasterTable):
recipe_file_template = '''
<code>{{data.name}}_{{data.version}}.bb</code>
+ {% if data.get_base_recipe_file %}
<a href="{% url 'customrecipedownload' extra.pid data.pk %}">
<i class="icon-download-alt" data-original-title="Download recipe
file"></i>
- </a>'''
+ </a>
+ {% endif %}'''
self.add_column(title="Recipe file",
static_data_name='recipe_file_download',
diff --git a/lib/toaster/toastergui/templates/customrecipe.html b/lib/toaster/toastergui/templates/customrecipe.html
index ea3c9c7324..aeb4466a20 100644
--- a/lib/toaster/toastergui/templates/customrecipe.html
+++ b/lib/toaster/toastergui/templates/customrecipe.html
@@ -4,6 +4,7 @@
{% load static %}
{% block pagecontent %}
+{% with recipe.get_base_recipe_file as base_recipe_file %}
<div class="section">
<ul class="breadcrumb">
<li>
@@ -99,8 +100,15 @@
<a class="btn btn-large span6 build-custom-image" href="#" style="width: 50%">
Build {{recipe.name}}
</a>
- <a href="{% url 'customrecipedownload' project.id recipe.id %}" class="btn btn-large span6" style="width: 50%">
+ <a href="{% url 'customrecipedownload' project.id recipe.id %}" class="btn btn-large span6" style="width: 50%"
+ {% if not base_recipe_file %}
+ disabled="disabled"
+ {% endif %}>
Download recipe file
+ {% if not base_recipe_file %}
+ <i class="icon-question-sign get-help"
+ data-original-title="The {{recipe.name}} recipe cannot yet be downloaded as the Based on recipe '{{recipe.base_recipe.name}}' has not yet been fetched"></i>
+ {% endif %}
</a>
</div>
<div id="no-results-special-{{table_name}}" class="air" style="display:none;">
@@ -177,7 +185,9 @@
<dt>Recipe file</dt>
<dd>
<code>{{recipe.name}}_{{recipe.version}}.bb</code>
+ {% if base_recipe_path %}
<a href="{% url 'customrecipedownload' project.pk recipe.pk %}"><i class="icon-share" title="" data-original-title="View recipe file"></i></a>
+ {% endif %}
</dd>
<dt>Layer</dt>
<dd><a href="{% url 'layerdetails' project.id recipe.layer_version.pk %}">{{recipe.layer_version.layer.name}}</a></dd>
@@ -220,4 +230,5 @@
</div>
</div>
+{% endwith %}{# end base_recipe_file #}
{% endblock %}