summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-03-04 22:54:22 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-08 18:12:38 +0000
commitec1b2faa352d2f7e75d5156fd3d18bb567b8c081 (patch)
treee203b74aa2d0f45ccce59ea58e8119789e993670
parent0f9aaf05a10fc93b333e4abcfac56a46062f7a33 (diff)
downloadopenembedded-core-contrib-ec1b2faa352d2f7e75d5156fd3d18bb567b8c081.tar.gz
linux-yocto/5.10: fix qemumips testimage failures
Integrating the following commit(s) to linux-yocto/5.10: 513e9332a00 qemumips32: disable CONFIG_COMPACTION As mentioned in yocto bug: https://bugzilla.yoctoproject.org/show_bug.cgi?id=13992 testimages are failing due to issues with kernel page migration/compaction function that does not work very well with MIPS kernel HIGHMEM that is needed for 512Mb. A valid workaround is to disable CONFIG_COMPACTION and the problematic migration functionality is also disabled. [YOCTO: #13992] Signed-off-by: Victor Kamensky <victor.kamensky7@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.10.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
index db17ffa5c4..26772a1acf 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "8dffd4d97d49439dae98e38b915729bca285f0cc"
-SRCREV_meta ?= "72ecf520873bd0e1a1d52db0a36d74ad88fd9824"
+SRCREV_meta ?= "513e9332a0092795b3b29eec0030b462ae4c8b6e"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
index 1bdacd86c4..7388e6ecda 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine_qemuarm ?= "55ff861a7f7be737c26b6c61f9cd170580dd3ccd"
SRCREV_machine ?= "34523d7c8476942eb062d4f0201f9410605afc6d"
-SRCREV_meta ?= "72ecf520873bd0e1a1d52db0a36d74ad88fd9824"
+SRCREV_meta ?= "513e9332a0092795b3b29eec0030b462ae4c8b6e"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.10.bb b/meta/recipes-kernel/linux/linux-yocto_5.10.bb
index c8ec0ae6b0..e17cd28601 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.10.bb
@@ -21,7 +21,7 @@ SRCREV_machine_qemux86 ?= "34523d7c8476942eb062d4f0201f9410605afc6d"
SRCREV_machine_qemux86-64 ?= "34523d7c8476942eb062d4f0201f9410605afc6d"
SRCREV_machine_qemumips64 ?= "36e98aa424aa3ceff3d446ee2cb3f44ddcae8c31"
SRCREV_machine ?= "34523d7c8476942eb062d4f0201f9410605afc6d"
-SRCREV_meta ?= "72ecf520873bd0e1a1d52db0a36d74ad88fd9824"
+SRCREV_meta ?= "513e9332a0092795b3b29eec0030b462ae4c8b6e"
# remap qemuarm to qemuarma15 for the 5.8 kernel
# KMACHINE_qemuarm ?= "qemuarma15"