aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-11 19:14:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-18 10:09:29 +0100
commitdb86b271c98dd50c641374ab6806b47a40ed134b (patch)
tree969c4985a62a8b6775828ffd8509f1dd2197f7d5
parentc9bd7f71b59e1c8e7436d65cd8ad6bfb29051c93 (diff)
downloadopenembedded-core-contrib-db86b271c98dd50c641374ab6806b47a40ed134b.tar.gz
mesa: remove hardware float patch
We don't need the texture float patches anymore, as the relevant patents have expired so this defaults to on now. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/mesa/files/0004-hardware-gloat.patch52
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.1.3.bb1
2 files changed, 0 insertions, 53 deletions
diff --git a/meta/recipes-graphics/mesa/files/0004-hardware-gloat.patch b/meta/recipes-graphics/mesa/files/0004-hardware-gloat.patch
deleted file mode 100644
index b676b078a3..0000000000
--- a/meta/recipes-graphics/mesa/files/0004-hardware-gloat.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 9bc2dad0257b778faf30edd5bc8f5c19ddf27351 Mon Sep 17 00:00:00 2001
-From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
-Date: Sun, 20 Mar 2016 13:27:04 +0100
-Subject: [PATCH 4/8] hardware gloat
-Organization: O.S. Systems Software LTDA.
-
-Upstream-Status: Inappropriate [not author]
-Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
----
- src/gallium/drivers/llvmpipe/lp_screen.c | 7 +++++++
- src/gallium/drivers/softpipe/sp_screen.c | 7 +++++++
- 2 files changed, 14 insertions(+)
-
-diff --git a/src/gallium/drivers/llvmpipe/lp_screen.c b/src/gallium/drivers/llvmpipe/lp_screen.c
-index 3f5d0327bf..86808e016b 100644
---- a/src/gallium/drivers/llvmpipe/lp_screen.c
-+++ b/src/gallium/drivers/llvmpipe/lp_screen.c
-@@ -449,6 +449,13 @@ llvmpipe_is_format_supported( struct pipe_screen *_screen,
- if (!format_desc)
- return FALSE;
-
-+ if ((bind & PIPE_BIND_RENDER_TARGET) &&
-+ format != PIPE_FORMAT_R9G9B9E5_FLOAT &&
-+ format != PIPE_FORMAT_R11G11B10_FLOAT &&
-+ util_format_is_float(format)) {
-+ return FALSE;
-+ }
-+
- assert(target == PIPE_BUFFER ||
- target == PIPE_TEXTURE_1D ||
- target == PIPE_TEXTURE_1D_ARRAY ||
-diff --git a/src/gallium/drivers/softpipe/sp_screen.c b/src/gallium/drivers/softpipe/sp_screen.c
-index 25f6f74f36..61629ef2ff 100644
---- a/src/gallium/drivers/softpipe/sp_screen.c
-+++ b/src/gallium/drivers/softpipe/sp_screen.c
-@@ -397,6 +397,13 @@ softpipe_is_format_supported( struct pipe_screen *screen,
- if (!format_desc)
- return FALSE;
-
-+ if ((bind & PIPE_BIND_RENDER_TARGET) &&
-+ format != PIPE_FORMAT_R9G9B9E5_FLOAT &&
-+ format != PIPE_FORMAT_R11G11B10_FLOAT &&
-+ util_format_is_float(format)) {
-+ return FALSE;
-+ }
-+
- if (sample_count > 1)
- return FALSE;
-
---
-2.18.0
-
diff --git a/meta/recipes-graphics/mesa/mesa_18.1.3.bb b/meta/recipes-graphics/mesa/mesa_18.1.3.bb
index 1c76f4b1b1..e4aad1d047 100644
--- a/meta/recipes-graphics/mesa/mesa_18.1.3.bb
+++ b/meta/recipes-graphics/mesa/mesa_18.1.3.bb
@@ -3,7 +3,6 @@ require ${BPN}.inc
SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
file://0002-Simplify-wayland-scanner-lookup.patch \
file://0003-winsys-svga-drm-Include-sys-types.h.patch \
- file://0004-hardware-gloat.patch \
file://0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
file://0006-Use-Python-3-to-execute-the-scripts.patch \
file://0007-dri-i965-Add-missing-time.h-include.patch \