aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2018-08-09 18:32:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-14 11:36:22 +0100
commitb159cb615feb7f27f8d2afc71f547742bb19cde0 (patch)
treeb75e1e76a9b8a110ba64455cad0a181962626cea
parent4eceae7e3e6dab935e2cf49b75148139192fc6e7 (diff)
downloadopenembedded-core-contrib-b159cb615feb7f27f8d2afc71f547742bb19cde0.tar.gz
libjpeg-turbo: fix timezone of reproducible build timestamp
Avoids producing different build results in different timezones. Uses UTC with SOURCE_DATE_EPOCH. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb b/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb
index 15353b5b5d..6be6aa572c 100644
--- a/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb
+++ b/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb
@@ -46,7 +46,7 @@ DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb
def get_build_time(d):
if d.getVar('SOURCE_DATE_EPOCH') != None:
import datetime
- return " --with-build-date="+ datetime.datetime.fromtimestamp(float(d.getVar('SOURCE_DATE_EPOCH'))).strftime("%Y%m%d")
+ return " --with-build-date="+ datetime.datetime.utcfromtimestamp(float(d.getVar('SOURCE_DATE_EPOCH'))).strftime("%Y%m%d")
return ""
EXTRA_OECONF_append_class-target = "${@get_build_time(d)}"