aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-08-21 18:24:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-23 07:45:32 +0100
commit2588c2aae11b7b480022dc11575295fdc792bf3f (patch)
tree63b9cad9dcdaf86ccdb87158f8380ae1fd345a1e
parentf2c1d7109014ef9d804c3a6967b96143834ff7bd (diff)
downloadopenembedded-core-contrib-2588c2aae11b7b480022dc11575295fdc792bf3f.tar.gz
perl: avoid using += with an over-ride
Using += with an over-ride can be a source of confusion so try to avoid the construct in core recipes. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.24.4.bb2
-rw-r--r--meta/recipes-devtools/perl/perl_5.24.4.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.24.4.bb b/meta/recipes-devtools/perl/perl-native_5.24.4.bb
index 90a1615551..affc9d5d78 100644
--- a/meta/recipes-devtools/perl/perl-native_5.24.4.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.24.4.bb
@@ -135,5 +135,5 @@ EOF
# Fix the path in sstate
SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
-PACKAGES_DYNAMIC_class-native += "^perl-module-.*native$"
+PACKAGES_DYNAMIC_class-native = "^perl-module-.*native$"
diff --git a/meta/recipes-devtools/perl/perl_5.24.4.bb b/meta/recipes-devtools/perl/perl_5.24.4.bb
index 4709d3e785..87a85a39d4 100644
--- a/meta/recipes-devtools/perl/perl_5.24.4.bb
+++ b/meta/recipes-devtools/perl/perl_5.24.4.bb
@@ -339,7 +339,7 @@ python split_perl_packages () {
}
PACKAGES_DYNAMIC += "^perl-module-.*(?<!\-native)$"
-PACKAGES_DYNAMIC_class-nativesdk += "^nativesdk-perl-module-.*"
+PACKAGES_DYNAMIC_class-nativesdk = "^nativesdk-perl-module-.*"
RPROVIDES_perl-lib = "perl-lib"