aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-03 13:37:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-03 13:45:03 +0100
commitc26542eb4e8707b9639ec309a44809a728839db8 (patch)
tree1127008340553f13ed312435d6473d0f2471dc53
parent1600c916ae410c57a783a5aa35abe07a3f673311 (diff)
downloadopenembedded-core-contrib-c26542eb4e8707b9639ec309a44809a728839db8.tar.gz
rpmresolve: fix reporting of multiple matches error
We were mistakenly writing what was meant to go to stderr into the output file, so when the "Multiple matches" error showed we weren't actually seeing the matches printed. Also change the wording of the "Unable to find package..." to "Unable to resolve package..." instead so that it makes more sense if it is printed after the "Multiple matches" error. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/rpmresolve/rpmresolve.c6
-rw-r--r--meta/recipes-devtools/rpm/rpmresolve_1.0.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/rpm/rpmresolve/rpmresolve.c b/meta/recipes-devtools/rpm/rpmresolve/rpmresolve.c
index 3613ee5a8d..4e9d055f24 100644
--- a/meta/recipes-devtools/rpm/rpmresolve/rpmresolve.c
+++ b/meta/recipes-devtools/rpm/rpmresolve/rpmresolve.c
@@ -185,7 +185,7 @@ int processPackages(rpmts *ts, int tscount, const char *packagelistfn, int ignor
char *value = NULL;
rc = getPackageStr(ts[i], keys[keyindex], RPMTAG_PACKAGEORIGIN, &value);
if(rc == 0)
- fprintf(outf, " %s\n", value);
+ fprintf(stderr, " %s\n", value);
else
fprintf(stderr, " (%s)\n", keys[keyindex]);
}
@@ -197,10 +197,10 @@ int processPackages(rpmts *ts, int tscount, const char *packagelistfn, int ignor
if( !found ) {
if( ignoremissing ) {
- fprintf(stderr, "unable to find package %s - ignoring\n", line);
+ fprintf(stderr, "Unable to resolve package %s - ignoring\n", line);
}
else {
- fprintf(stderr, "unable to find package %s\n", line);
+ fprintf(stderr, "Unable to resolve package %s\n", line);
missing = 1;
}
}
diff --git a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
index 3ce4369d0c..ea542e1cc3 100644
--- a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
+++ b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "OpenEmbedded RPM resolver - performs RPM database lookups in batc
DEPENDS = "rpm"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r1"
+PR = "r2"
SRC_URI = "file://rpmresolve.c"