aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-10-03 14:23:26 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-03 12:39:59 +0100
commit53b3103abdf21123b1c7be49b05cfe97a7cd9ed7 (patch)
tree79eaf1cd20aeead1d6757bc36034a16c33f9a30a
parente71c6bb75239926aceebbb53d158cbf8de6112a4 (diff)
downloadopenembedded-core-contrib-53b3103abdf21123b1c7be49b05cfe97a7cd9ed7.tar.gz
qemu: add wrapper for qemu-mips binary
qemu-mips user emulation binary segfaults when running any kind of binary. This is due to a MMU access fault in the virtual CPU. This problem has been introduced in qemu when 4GB of vmem were reserved for 32-on-64 bit. This workaround will need to be reverted once the proper fix is found. [YOCTO #3143] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.2.0.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_1.2.0.bb b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
index 191ee48e06..cbdb4d472b 100644
--- a/meta/recipes-devtools/qemu/qemu_1.2.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
@@ -17,7 +17,7 @@ SRC_URI = "\
SRC_URI[md5sum] = "78eb1e984f4532aa9f2bdd3c127b5b61"
SRC_URI[sha256sum] = "c8b84420d9f4869397f84cad2dabd9a475b7723d619a924a873740353e9df936"
-PR = "r2"
+PR = "r3"
SRC_URI_append_virtclass-nativesdk = "\
file://relocatable_sdk.patch \
@@ -29,6 +29,19 @@ do_configure_prepend_virtclass-nativesdk() {
sed -i 's/-lX11//g' Makefile.target
fi
}
+
+# The following fragment will create a wrapper for qemu-mips user emulation
+# binary in order to work around a segmentation fault issue. Basically, by
+# default, the reserved virtual address space for 32-on-64 bit is set to 4GB.
+# This will trigger a MMU access fault in the virtual CPU. With this change,
+# the qemu-mips works fine.
+# IMPORTANT: This piece needs to be removed once the root cause is fixed!
+do_install_append() {
+ create_wrapper ${D}/${bindir}/qemu-mips \
+ QEMU_RESERVED_VA=0x0
+}
+# END of qemu-mips workaround
+
do_configure_prepend_virtclass-native() {
# Undo the -lX11 added by linker-flags.patch, don't assume that host has libX11 installed
sed -i 's/-lX11//g' Makefile.target