aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-08-29 16:43:47 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-31 14:42:01 +0100
commit6ce8037550902281aaaca2d6e27b788adbd2d1a8 (patch)
tree1f4c299531b4f4ec698ba6c9d663bcf3d6ed4a73
parent0ca8fc821d66a9b79f247925d1fc4b6b7d775c94 (diff)
downloadopenembedded-core-contrib-6ce8037550902281aaaca2d6e27b788adbd2d1a8.tar.gz
openssl: do not tweak so names, use PRIVATE_LIBS instead
The tweaking was not sufficient to prevent package dependency issues, but there is a standard mechanism to do exactly that kind of prevention which I wasn't aware of. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.1-pre9.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.1-pre9.bb b/meta/recipes-connectivity/openssl/openssl_1.1.1-pre9.bb
index 1917c3301f..3f4e19f296 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.1-pre9.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.1-pre9.bb
@@ -149,14 +149,10 @@ do_install_append_class-nativesdk () {
do_install_ptest () {
cp -r * ${D}${PTEST_PATH}
-
- # Putting .so files in ptest package will mess up the dependencies of the main openssl package
- # so we rename them to .so.ptest and patch the test accordingly
- mv ${D}${PTEST_PATH}/libcrypto.so ${D}${PTEST_PATH}/libcrypto.so.ptest
- mv ${D}${PTEST_PATH}/libssl.so ${D}${PTEST_PATH}/libssl.so.ptest
- sed -i 's/$target{shared_extension_simple}/".so.ptest"/' ${D}${PTEST_PATH}/test/recipes/90-test_shlibload.t
}
+PRIVATE_LIBS_${PN}-ptest = "libcrypto.so.1.1 libssl.so.1.1"
+
# Add the openssl.cnf file to the openssl-conf package. Make the libcrypto
# package RRECOMMENDS on this package. This will enable the configuration
# file to be installed for both the openssl-bin package and the libcrypto