summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-08-01 19:41:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-01 14:08:58 +0100
commit9159db64d3b3c7633deb135e683317fd3e98852c (patch)
tree537d086c12016a9f69de9357842b1fb16fcf890a
parent30912ba084aa8600156edddbe4f2db0b85e869d0 (diff)
downloadopenembedded-core-contrib-9159db64d3b3c7633deb135e683317fd3e98852c.tar.gz
python3-pytest: display correct version info
It does not show correct version info of python3-pytest: $ pip3 list | grep pytest pytest 0.0.0 pytest requires setuptools-scm in setup.cfg. It could be met by adding python3-setuptools-scm-native to dependency and then it will not download egg file of setuptools-scm during do_compile any more. So remove 0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch and depend on python3-setuptools-scm-native to make it show the correct version info. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch36
-rw-r--r--meta/recipes-devtools/python/python3-pytest_6.2.4.bb4
2 files changed, 2 insertions, 38 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta/recipes-devtools/python/python3-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
deleted file mode 100644
index 1abd531c62..0000000000
--- a/meta/recipes-devtools/python/python3-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From ead04f2da75efeca3369feff6161ea4a8baecbc9 Mon Sep 17 00:00:00 2001
-From: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
-Date: Wed, 28 Aug 2019 16:12:27 +0900
-Subject: [PATCH] setup.py: remove the setup_requires for setuptools-scm
-
-The setup_requires argument forces the download of the egg file for setuptools-scm
-during the do_compile phase. This download is incompatible with the typical fetch
-and mirror structure. The only usage of scm is the generation of the _version.py
-file and in the release tarball it is already correctly created
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Derek Straka <derek@asterius.io>
-
-Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
-
-Rebase for pytest 6.1.0.
-
-Signed-off-by: Kai Kang <kai.kang@windriver.com>
-
----
- setup.cfg | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/setup.cfg b/setup.cfg
-index 6ed0792..0137090 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -53,7 +53,6 @@ package_dir =
- =src
- setup_requires =
- setuptools>=>=42.0
-- setuptools-scm>=3.4
- zip_safe = no
-
- [options.entry_points]
diff --git a/meta/recipes-devtools/python/python3-pytest_6.2.4.bb b/meta/recipes-devtools/python/python3-pytest_6.2.4.bb
index 0df44d58c7..f0fd30aeda 100644
--- a/meta/recipes-devtools/python/python3-pytest_6.2.4.bb
+++ b/meta/recipes-devtools/python/python3-pytest_6.2.4.bb
@@ -5,10 +5,10 @@ DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scal
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
-SRC_URI:append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch "
-
SRC_URI[sha256sum] = "50bcad0a0b9c5a72c8e4e7c9855a3ad496ca6a881a3641b4260605450772c54b"
+DEPENDS = "python3-setuptools-scm-native"
+
inherit update-alternatives pypi setuptools3
RDEPENDS:${PN}:class-target += " \