summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Cesar Zaneti <paulo.zaneti@gmail.com>2021-04-19 10:55:55 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-23 10:12:12 +0100
commitf2d1523b19cb066a4a06609f036822fe4a8b43f0 (patch)
treed2a00dcf831ffc708d4c8da820e2bbf389c7fbb1
parentca72375a3bbebcb9a7af4dce3c06716ac2c0f5fc (diff)
downloadopenembedded-core-contrib-f2d1523b19cb066a4a06609f036822fe4a8b43f0.tar.gz
perl: fix startperl configuration option for perl-native
Unlike vanilla Perl "Configure" script, perl-cross "configure" does not derive "startperl" from "bin". It instead derives from "perlpath". This patch aims to fix "startperl" configuration option for perl-native by correctly setting "perlpath" on perl-cross "configure" script. It also changes do_install_append_class-native task to comply with cpan_do_install task. Signed-off-by: Paulo Cesar Zaneti <paulo.zaneti@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.32.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.32.1.bb b/meta/recipes-devtools/perl/perl_5.32.1.bb
index b28040c7fb..73d66f6656 100644
--- a/meta/recipes-devtools/perl/perl_5.32.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.32.1.bb
@@ -95,6 +95,7 @@ do_configure_class-nativesdk() {
do_configure_class-native() {
./configure --prefix=${prefix} \
-Dbin=${bindir}/perl-native \
+ -Dperlpath=${bindir}/perl-native/perl \
-Duseshrplib \
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
@@ -171,8 +172,8 @@ do_install_append_class-native () {
create_wrapper ${D}${bindir}/perl-native/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl5/site_perl/${PV}:${STAGING_LIBDIR}/perl5/vendor_perl/${PV}:${STAGING_LIBDIR}/perl5/${PV}'
# Use /usr/bin/env nativeperl for the perl script.
- for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
- sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
+ for f in `grep -Il '#! *${bindir}/perl-native.*/perl' ${D}/${bindir}/*`; do
+ sed -i -e 's|${bindir}/perl-native.*/perl|/usr/bin/env nativeperl|' $f
done
}