summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@windriver.com>2021-04-26 07:45:09 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-27 15:11:43 +0100
commit46a60f67562a6ae227e018228212fc797d1f2795 (patch)
treeb2fd3d61644e33f28ccc7e5854926296e8bd3d7d
parent7d8d0b90bea7ea01e1e9ab0ff98f22431f68a506 (diff)
downloadopenembedded-core-contrib-46a60f67562a6ae227e018228212fc797d1f2795.tar.gz
qemu-system-native: install qmp python module
The qmp python module supports the Qemu Machine Protocol [0]. This module needs to be installed in a known location so the qemurunner python script can find the qmp module. This change causes it to be installed in the recipe-sysroot-native of the target image and that directory can be added to the python sys.path that needs to use the qmp.py module. [0] https://github.com/qemu/qemu/blob/master/docs/interop/qmp-spec.txt Signed-off-by: Saul Wold <saul.wold@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb b/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb
index 222b55cbc6..390dadea48 100644
--- a/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb
+++ b/meta/recipes-devtools/qemu/qemu-system-native_5.2.0.bb
@@ -1,5 +1,7 @@
BPN = "qemu"
+inherit python3-dir
+
require qemu-native.inc
# As some of the files installed by qemu-native and qemu-system-native
@@ -23,4 +25,7 @@ do_install_append() {
rm -f ${D}${datadir}/qemu/trace-events-all
rm -rf ${D}${datadir}/qemu/keymaps
rm -rf ${D}${datadir}/icons/
+
+ # Install qmp.py to be used with testimage
+ install -D ${S}/python/qemu/qmp.py ${D}${PYTHON_SITEPACKAGES_DIR}/qmp.py
}