aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2017-03-08 16:48:13 +0000
committerJoshua Lock <joshua.g.lock@intel.com>2017-03-08 17:01:34 +0000
commit1ec75104e2b1c51911905e8318f36b291a7dccef (patch)
treed24a6675dbed56ec970bb891dc3a3a6da59e2a27
parent3658da86e57dc87ac3957b05f853a7f1a56bfab2 (diff)
downloadopenembedded-core-contrib-1ec75104e2b1c51911905e8318f36b291a7dccef.tar.gz
chkconfig-alternatives-native: fix obey_variables
This postfunc assumes it's run from S, whereas that seems not to always be the case in practice. Explicitly define the full path of the file we wish to sed. Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb b/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
index c0f7f1674f..87fa8eb605 100644
--- a/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
+++ b/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
@@ -21,7 +21,7 @@ inherit native
# into the sysroot, as we may use them to construct the rootfs. As such, we
# only adjust the paths to match the metadata for the target, not native.
obey_variables () {
- sed -i 's,ALTERNATIVES_ROOT,OPKG_OFFLINE_ROOT,' alternatives.c
+ sed -i 's,ALTERNATIVES_ROOT,OPKG_OFFLINE_ROOT,' ${S}/alternatives.c
}
do_compile () {