aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-01-18 13:13:27 +0000
committerJoshua Lock <joshua.g.lock@intel.com>2016-01-18 13:13:27 +0000
commitc929ba4661efe2c317261602c9044a6e96380569 (patch)
tree5722123ebcf2bb5c290cdb2f6bde46ffa59e165a
parent12c7d3950f4dc3c69a954fa1236217b4c17a07f8 (diff)
downloadopenembedded-core-contrib-c929ba4661efe2c317261602c9044a6e96380569.tar.gz
build-compare: remove versioned depends before comparing
Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
-rw-r--r--meta/recipes-devtools/build-compare/build-compare_git.bb1
-rw-r--r--meta/recipes-devtools/build-compare/files/0001-Hack-to-remove-dependencies-on-the-versioned-package.patch37
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/build-compare/build-compare_git.bb b/meta/recipes-devtools/build-compare/build-compare_git.bb
index d1591754c5..f456aa3c7e 100644
--- a/meta/recipes-devtools/build-compare/build-compare_git.bb
+++ b/meta/recipes-devtools/build-compare/build-compare_git.bb
@@ -10,6 +10,7 @@ PV = "2015.07.15+git${SRCPV}"
SRC_URI = "git://github.com/openSUSE/build-compare.git \
file://Ignore-DWARF-sections.patch;striplevel=1 \
file://0001-Add-support-for-deb-and-ipk-packaging.patch \
+ file://0001-Hack-to-remove-dependencies-on-the-versioned-package.patch \
"
SRCREV = "0b929c8a254b2bdb9392124dcd6836129dc125f9"
diff --git a/meta/recipes-devtools/build-compare/files/0001-Hack-to-remove-dependencies-on-the-versioned-package.patch b/meta/recipes-devtools/build-compare/files/0001-Hack-to-remove-dependencies-on-the-versioned-package.patch
new file mode 100644
index 0000000000..0dcd14fc34
--- /dev/null
+++ b/meta/recipes-devtools/build-compare/files/0001-Hack-to-remove-dependencies-on-the-versioned-package.patch
@@ -0,0 +1,37 @@
+From 283b8b9948fd045217157b2182cc499c135ae543 Mon Sep 17 00:00:00 2001
+From: Joshua Lock <joshua.g.lock@intel.com>
+Date: Mon, 18 Jan 2016 13:09:02 +0000
+Subject: [PATCH] Hack to remove dependencies on the versioned package in a
+ control file
+
+The intention is to remove dependencies on the matchingversioned package in
+the control files of -dbg and -dev packages. This hack is rather inelegant
+but useful as a test.
+
+A more elegant solution likely requires reading of the GNU Awk manual:
+http://www.gnu.org/software/gawk/manual/gawk.html
+
+Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
+---
+ functions.sh | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/functions.sh b/functions.sh
+index 7beadfa..db7bd94 100644
+--- a/functions.sh
++++ b/functions.sh
+@@ -264,8 +264,11 @@ function cmp_spec ()
+ }
+
+ function adjust_controlfile () {
++ sed -i "s/$(awk '/^Version: / {print $2;}' $1/control)//" $1/control
+ cat $1/control | sed '/^Version: /d' > $1/control.fixed
+ mv $1/control.fixed $1/control
++
++ sed -i "s/$(awk '/^Version: / {print $2;}' $2/control)//" $2/control
+ cat $2/control | sed '/^Version: /d' > $2/control.fixed
+ mv $2/control.fixed $2/control
+ }
+--
+2.5.0
+