aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>2016-11-23 13:47:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:12 +0000
commit85280798306c0c1b1f36e5a10394ffaa7c4041f9 (patch)
tree43fe0619a99c2f82e9fd83ba26a65d01d877e7dd
parentbd565243d75d0d13360a86aef6acaa594875b849 (diff)
downloadopenembedded-core-contrib-85280798306c0c1b1f36e5a10394ffaa7c4041f9.tar.gz
valgrind: Use MIPS MACHINE_OVERRIDES
The mipsarch* MACHINE_OVERRIDES can be used to pass the same parameters to MIPS pre-R2 and R6 ISA variants. Use them to reduce duplication in supporting MIPS R6 ISA. Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.12.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.12.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.12.0.bb
index 2474bbc10f..637b723313 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.12.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.12.0.bb
@@ -36,8 +36,11 @@ COMPATIBLE_HOST_armv4 = 'null'
COMPATIBLE_HOST_armv5 = 'null'
COMPATIBLE_HOST_armv6 = 'null'
-# valgrind doesn't like mips soft float
-COMPATIBLE_HOST_mipsarch = "${@bb.utils.contains("TARGET_FPU", "soft", "null", ".*-linux", d)}"
+# Disable for some MIPS variants
+COMPATIBLE_HOST_mipsarcho32 = "${@bb.utils.contains("TARGET_FPU", "soft", "null", ".*-linux", d)}"
+COMPATIBLE_HOST_mipsarchn32 = 'null'
+COMPATIBLE_HOST_mipsarchn64 = "${@bb.utils.contains("TARGET_FPU", "soft", "null", ".*-linux", d)}"
+COMPATIBLE_HOST_mipsarchr6 = 'null'
inherit autotools ptest