aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-10 21:39:36 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-10 22:44:51 +0100
commitf609bf5525450bfdb8e0864d44c41cce7f9319c9 (patch)
treed2c9cdd3ebcac7a8176c330cd3e350f7358cd333
parent5bed2bb831b379a8fbf2f725435af4b7c934359e (diff)
downloadopenembedded-core-contrib-f609bf5525450bfdb8e0864d44c41cce7f9319c9.tar.gz
gdbm: Resolve host contamination issue
The autoconf macros detect the presence of -ldbm or -lndbm on the host system and add the library to link against, for now good reason I can explain. This patch makes the build behave determinstically whether they're present or not. Other than the extra linkage, there doesn't appear to be any other change in behaviour from these options and they look like dead code. The extra linkage can cause problems where sstate is used on a machine where the extra librbary isn't present causing build failures. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.10.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.10.bb b/meta/recipes-support/gdbm/gdbm_1.10.bb
index 6b68d27cce..498ad9985e 100644
--- a/meta/recipes-support/gdbm/gdbm_1.10.bb
+++ b/meta/recipes-support/gdbm/gdbm_1.10.bb
@@ -16,6 +16,9 @@ inherit autotools gettext lib_package
# Needed for dbm python module
EXTRA_OECONF = "-enable-libgdbm-compat"
+# Stop presence of dbm/nbdm on the host contaminating builds
+CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
+
BBCLASSEXTEND = "native nativesdk"
do_install_append () {