aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-03-25 12:19:17 +0000
committerJoshua Lock <josh@linux.intel.com>2010-03-26 10:29:18 +0000
commit678537c6844662f7b156587fc324bdfe0aa03621 (patch)
tree02a2f577d4c245661f5e967dbd94f16b5867f8f9
parenta2d5806f5d5eebea3828b18cffa3cb0df327a9b8 (diff)
downloadopenembedded-core-contrib-678537c6844662f7b156587fc324bdfe0aa03621.tar.gz
pyton-pycurl: Add new recipe from OE.dev
Add python-pycurl_7.19.0 from OE.dev with some tweaks to enable a native version. This package is a dependancy of newer Yum Signed-off-by: Joshua Lock <josh@linux.intel.com>
-rw-r--r--meta/packages/python/python-pycurl/no-static-link.patch14
-rw-r--r--meta/packages/python/python-pycurl_7.19.0.bb23
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/packages/python/python-pycurl/no-static-link.patch b/meta/packages/python/python-pycurl/no-static-link.patch
new file mode 100644
index 0000000000..b7c5ab9c9c
--- /dev/null
+++ b/meta/packages/python/python-pycurl/no-static-link.patch
@@ -0,0 +1,14 @@
+Index: pycurl-7.18.2/setup.py
+===================================================================
+--- pycurl-7.18.2.orig/setup.py
++++ pycurl-7.18.2/setup.py
+@@ -97,8 +97,7 @@ else:
+ else:
+ extra_compile_args.append(e)
+ libs = split_quoted(
+- os.popen("'%s' --libs" % CURL_CONFIG).read()+\
+- os.popen("'%s' --static-libs" % CURL_CONFIG).read())
++ os.popen("'%s' --libs" % CURL_CONFIG).read())
+ for e in libs:
+ if e[:2] == "-l":
+ libraries.append(e[2:])
diff --git a/meta/packages/python/python-pycurl_7.19.0.bb b/meta/packages/python/python-pycurl_7.19.0.bb
new file mode 100644
index 0000000000..84b01dc50f
--- /dev/null
+++ b/meta/packages/python/python-pycurl_7.19.0.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libcurl Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "curl"
+SRCNAME = "pycurl"
+PR = "r0"
+
+SRC_URI = "\
+ http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
+ file://no-static-link.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# need to export these variables for python-config to work
+export BUILD_SYS
+export HOST_SYS
+
+RDEPENDS = "python-core curl"
+
+BBCLASSEXTEND = "native"