summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Laplante <chris.laplante@agilent.com>2020-09-14 11:33:18 -0400
committerSteve Sakoman <steve@sakoman.com>2020-09-28 07:55:37 -1000
commitec2a17001a2a0180ecdb0b946ff8f7673e14ba24 (patch)
tree0f0e5cbb6524eb5169d5887cf7a781530140f430
parent5919afe43083d9d0b818c26ca4d6c175efa0f7b5 (diff)
downloadopenembedded-core-contrib-ec2a17001a2a0180ecdb0b946ff8f7673e14ba24.tar.gz
cve-update-db-native: be less magical about checking whether the cve-check class is enabled
Signed-off-by: Chris Laplante <chris.laplante@agilent.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit cbc717350b21fb417fa6f83621022ac633a26124) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index 328f6ab364..2c0e508e32 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -13,8 +13,7 @@ deltask do_install
deltask do_populate_sysroot
python () {
- cve_check_db_file = d.getVar("CVE_CHECK_DB_FILE")
- if not cve_check_db_file:
+ if not bb.data.inherits_class("cve-check", d):
raise bb.parse.SkipRecipe("Skip recipe when cve-check class is not loaded.")
if os.path.exists("%s-journal" % cve_check_db_file ):