summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-09-15 12:05:32 +0100
committerSteve Sakoman <steve@sakoman.com>2020-09-28 07:55:37 -1000
commit07910054c75a084dcfb10c86c1bf69b68989f587 (patch)
treeef712bfaf8b3735814c030b56dcf11be00fb794a
parentd888a11a372be5886c6894e5b38514e44498934d (diff)
downloadopenembedded-core-contrib-07910054c75a084dcfb10c86c1bf69b68989f587.tar.gz
sato-screenshot: improve .la removal
Don't assume that the .la files are installed, because some libtool alternatives don't install these. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit e545ae3a7961111ceb4e2a468e9ec53cebfed721) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
index f6dac2cf88..2b1f513f1c 100644
--- a/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb
@@ -21,7 +21,7 @@ inherit autotools pkgconfig features_check
FILES_${PN} += "${libdir}/matchbox-panel/*.so"
do_install_append () {
- rm ${D}${libdir}/matchbox-panel/*.la
+ rm -f ${D}${libdir}/matchbox-panel/*.la
}
# The matchbox-panel-2 requires x11 in DISTRO_FEATURES