summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-13 23:57:13 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-15 17:52:49 +0100
commit7d8407583033ea70039dd7e475c325efcf857c18 (patch)
tree159ddead8f4099ad12e1ecfb53f53621e5db4ce9
parentec7f0ba9bfd8a102e1ca6ab2f93bcb13fd819d95 (diff)
downloadopenembedded-core-contrib-7d8407583033ea70039dd7e475c325efcf857c18.tar.gz
valgrind: Include debugging symbols in ptests
About half the ptests will fail if the executables deployed as part of the ptest package are stripped. We therefore need to add a dependency on the dbg symbols package and silence the QA test which would complain about this since we really do want it in this case. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.15.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
index 9749fdb244..3b3d0f02f7 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
@@ -108,12 +108,13 @@ RDEPENDS_${PN} += "perl"
# redirect functions like strlen.
RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
-RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
+RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob ${PN}-dbg"
RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
# One of the tests contains a bogus interpreter path on purpose.
# Skip file dependency check
SKIP_FILEDEPS_${PN}-ptest = '1'
+INSANE_SKIP_${PN}-ptest = "debug-deps"
do_compile_ptest() {
oe_runmake check