summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2010-09-29 12:40:36 -0500
committerSaul Wold <Saul.Wold@intel.com>2010-09-30 10:05:43 -0700
commitce373c7cc330562594da95ba14c463acb2c88f6e (patch)
treedc561db5f59cffdc7416fdbd27e243448ac215fe
parentfad896d4ea82b1cabcabbdf446a0c237f0005502 (diff)
downloadopenembedded-core-contrib-ce373c7cc330562594da95ba14c463acb2c88f6e.tar.gz
rpm_5.1.10: Disable dependency loop message
[BUGID #332] Disable the dependency loop message that looked like an error had occured. This is really a debug message. Also remove the "remove: " debug message about which side of the dep loop it is removing to resolve the circular dependency. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-no-loop.patch38
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.1.10.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-no-loop.patch b/meta/recipes-devtools/rpm/rpm/rpm-no-loop.patch
new file mode 100644
index 0000000000..1f0dbcbef9
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-no-loop.patch
@@ -0,0 +1,38 @@
+The LOOP: ... messages appear to be errors, but in reality they are
+simply debug messages that indicate there is one or more dependency
+loop within the system.
+
+Due to Poky packages owning all of the directories they use, a large
+number of depedency loops may be present. So disabling this message
+seems to make the most sense.
+
+Signed-off-by: mark.hatle@windriver.com
+
+diff -ur rpm-5.1.10.orig/lib/depends.c rpm-5.1.10/lib/depends.c
+--- rpm-5.1.10.orig/lib/depends.c 2010-09-29 12:23:48.307048065 -0500
++++ rpm-5.1.10/lib/depends.c 2010-09-29 12:33:23.306022259 -0500
+@@ -2044,9 +2044,11 @@
+ * Attempt to unravel a dependency loop by eliminating Requires's.
+ */
+ if (zap) {
++#if 0
+ rpmlog(msglvl,
+ _("removing %s \"%s\" from tsort relations.\n"),
+ (rpmteNEVRA(p) ? rpmteNEVRA(p) : "???"), dp);
++#endif
+ rpmteTSI(p)->tsi_count--;
+ if (tsi_prev) tsi_prev->tsi_next = tsi->tsi_next;
+ tsi->tsi_next = NULL;
+@@ -2676,10 +2678,12 @@
+ /* Unchain predecessor loop. */
+ rpmteTSI(p)->tsi_chain = NULL;
+
++#if 0
+ if (!printed) {
+ rpmlog(msglvl, _("LOOP:\n"));
+ printed = 1;
+ }
++#endif
+
+ /* Find (and destroy if co-requisite) "q <- p" relation. */
+ dp = zapRelation(q, p, 1, &nzaps, msglvl);
diff --git a/meta/recipes-devtools/rpm/rpm_5.1.10.bb b/meta/recipes-devtools/rpm/rpm_5.1.10.bb
index e5ccf8e99d..cbae3f3b31 100644
--- a/meta/recipes-devtools/rpm/rpm_5.1.10.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.1.10.bb
@@ -12,6 +12,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.1/SNAPSHOT/${BPN}-${PV}.tar.gz \
file://rpm-autoconf.patch \
file://remove-compiled-tests.patch;apply=no \
file://perfile_rpmdeps.sh \
+ file://rpm-no-loop.patch \
"
inherit autotools gettext