summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Rajotte <jonathan.rajotte-julien@efficios.com>2019-03-12 21:13:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-18 11:08:36 +0000
commita266788c0037173b41e5e7a4b39b38b80333b87b (patch)
tree8c30685b6be682bc6f070ce4fdc866b4af585bd1
parentafea472cdc5e72e2794b30b00f68e59ffb1e104c (diff)
downloadopenembedded-core-contrib-a266788c0037173b41e5e7a4b39b38b80333b87b.tar.gz
lttng-tools ptest: add missing dependencies
Multiple tests are failing due to missing dependencies on a bare core-image-minimal build with only lttng-tools ptest present. "getconf LONG_BIT" is used to get the bitness of the host to run the correct consumerd. Depend on glibc-utils. perl-module-overloading is needed to validate trace. babelstats.pl "head -c" is used to generate a random string. It is easier to depends on coreutils to get a feature complete "head" than to enable to "fancy head" feature of busybox. See utils.sh randstring. "taskset" is used in a couple of scripts to ensure that events generated finish in the same buffer. Depend on util-linux. [RP: Tweak for glibc/musl handling] Signed-off-by: Jonathan Rajotte <jonathan.rajotte-julien@efficios.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb13
1 files changed, 3 insertions, 10 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb b/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
index 9d21fb00bf..8c711eb79c 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.10.6.bb
@@ -11,7 +11,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \
DEPENDS = "liburcu popt libxml2 util-linux"
RDEPENDS_${PN} = "libgcc"
-RDEPENDS_${PN}-ptest += "make perl bash gawk ${PN} babeltrace procps"
+RDEPENDS_${PN}-ptest += "make perl bash gawk ${PN} babeltrace procps perl-module-overloading coreutils util-linux"
+RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
+RDEPENDS_${PN}-ptest_append_libc-musl = " musl-utils"
# babelstats.pl wants getopt-long
RDEPENDS_${PN}-ptest += "perl-module-getopt-long"
@@ -141,15 +143,6 @@ do_install_ptest () {
-e 's#\(^test.*LDADD.=\)#disable\1#g' \
-i ${D}${PTEST_PATH}/tests/unit/Makefile
- #
- # Disable notification tools tests as currently
- # these hang and cause the rest of the ptests to timeout
- #
- sed -e 's#tools/notification/test_notification_ust##g' \
- -e 's#tools/notification/test_notification_kernel##g' \
- -e 's#tools/notification/test_notification_multi_app##g' \
- -i ${D}${PTEST_PATH}/tests/regression/Makefile
-
# Substitute links to installed binaries.
for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd lttng-crash; do
exedir="${D}${PTEST_PATH}/src/bin/${prog}"