summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-05-01 22:00:01 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-09 21:39:46 +0100
commit3804784b6200f82f5d8d6f533ce5e1a36ee2aeac (patch)
tree709e8902e551bca670dc2818c08aadb077b55d78
parent0023aa21687287754c972c5e8edd527822e4e7c0 (diff)
downloadopenembedded-core-contrib-3804784b6200f82f5d8d6f533ce5e1a36ee2aeac.tar.gz
qt4-graphics-system: set graphic system in profile instead of X11 session
To allow the use of Qt applications started manually to use the configured graphics system the setting needs to be available in user environment. This moves the setting to /etc/profile.d ensuring it is set and available. This allow the removal of x11-common as dependency. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
index bae0340faf..e816a90ea8 100644
--- a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
+++ b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
@@ -3,10 +3,9 @@ SECTION = "x11/base"
LICENSE = "MIT-X"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-QT_GRAPHICS_SYSTEM ?= "raster"
+PR = "r1"
-# xserver-common, x11-common
-VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+QT_GRAPHICS_SYSTEM ?= "raster"
def _get_extra_rdepends(d):
gs = d.getVar('QT_GRAPHICS_SYSTEM', True)
@@ -16,12 +15,11 @@ def _get_extra_rdepends(d):
return ""
do_install () {
- install -d ${D}/${sysconfdir}/X11/Xsession.d/
- cfg_file=${D}/${sysconfdir}/X11/Xsession.d/85xqt-graphicssystem
+ install -d ${D}/${sysconfdir}/profile.d/
+ cfg_file=${D}/${sysconfdir}/profile.d/qt-graphicssystem
echo "export QT_GRAPHICSSYSTEM=${QT_GRAPHICS_SYSTEM}" > $cfg_file
- chmod +x $cfg_file
}
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_xserver_common} ${@_get_extra_rdepends(d)}"
+RDEPENDS_${PN} = "${@_get_extra_rdepends(d)}"
PACKAGE_ARCH = "${MACHINE_ARCH}"