summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 13:30:10 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-27 11:26:58 +0000
commit289fd2bf61d0761a93d17f18b9079fc9f61e0031 (patch)
tree054f573fdd37c12359ebd1c0b550e9f985aa4495
parent81f009d173f24501ab0e04d845db74ecb5f8e332 (diff)
downloadopenembedded-core-contrib-289fd2bf61d0761a93d17f18b9079fc9f61e0031.tar.gz
yaffs2: fix checkpoint functionality
Updating the linux-yocto SRCREVs to pull in the following change: Author: He Zhe <zhe.he@windriver.com> Date: Wed Dec 2 01:31:31 2015 -0500 fs/yaffs2: fix missing checkpoint on yaffs For yaffs file system, the mode of reading or writing is restricted at four pointer where are mnt->mnt_flags,mnt->mnt_sb->s_flags,mtd->flags and dev->read_only,the first three is used handle file and file system(eg,remount) operation, and last one(dev->read_only) almost is used handle checkpoint of yaffs2. However, in current code, the dev->read_only only can be changed at first time when the yaffs2 file system is mounted, later it can't be changed again(eg,mount -o remount), the result is that the checkpoint's saving operation always can't succeed if you set readonly mode for yaffs2 file system when it is mounted at the first time. To fix this issue, we implement yaffs_remount_fs() which allows the rootfs to be remounted as r/w. Signed-off-by: Wenlin Kang <wenlin.kang@windriver.com> Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 6bb38f8c05..1eb032bfe6 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -2,8 +2,8 @@ KBRANCH ?= "standard/preempt-rt/base"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "190c42da30140d227cc948ed5fa8fee8467d55f3"
-SRCREV_meta ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
+SRCREV_machine ?= "ed3fa3e6d62c1fb3411099478c69cef4e3d4f415"
+SRCREV_meta ?= "46bb64d605fd336d99fa05bab566b9553b40b4b4"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index cd4f2acff6..66c8a6575e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.1.13"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
-SRCREV_meta ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
+SRCREV_machine ?= "4e659b86ffcf20ece27f42a671853d5f42d52a6c"
+SRCREV_meta ?= "46bb64d605fd336d99fa05bab566b9553b40b4b4"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index 776620261f..12245295a3 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "2494184ad34764bdfa1bfd9a57eabfb34d170c0e"
-SRCREV_machine_qemuarm64 ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
-SRCREV_machine_qemumips ?= "85a76c24f5aaa99618fdb15d5f3966a2e03cd572"
-SRCREV_machine_qemuppc ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
-SRCREV_machine_qemux86 ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
-SRCREV_machine_qemux86-64 ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
-SRCREV_machine_qemumips64 ?= "79181dc5284d9831d240d7ba58a2b574f6528b90"
-SRCREV_machine ?= "2c30f87db7824e90b0b096eee3a5b7f93c84b079"
-SRCREV_meta ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
+SRCREV_machine_qemuarm ?= "c19d15710a9e0a01a83a1ac03356390bc26a01f7"
+SRCREV_machine_qemuarm64 ?= "4e659b86ffcf20ece27f42a671853d5f42d52a6c"
+SRCREV_machine_qemumips ?= "ca7ddd2ce6e7c3fb599512bcc31a1de23ecb589d"
+SRCREV_machine_qemuppc ?= "4e659b86ffcf20ece27f42a671853d5f42d52a6c"
+SRCREV_machine_qemux86 ?= "4e659b86ffcf20ece27f42a671853d5f42d52a6c"
+SRCREV_machine_qemux86-64 ?= "4e659b86ffcf20ece27f42a671853d5f42d52a6c"
+SRCREV_machine_qemumips64 ?= "5945b7d7abce3ede46ae133a24420751d99ea55b"
+SRCREV_machine ?= "4e659b86ffcf20ece27f42a671853d5f42d52a6c"
+SRCREV_meta ?= "46bb64d605fd336d99fa05bab566b9553b40b4b4"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"