aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-06-19 14:55:53 +0100
committerSaul Wold <sgw@linux.intel.com>2013-07-02 07:46:03 -0700
commitbcbb34c26a235a103b46aa5c8ae7b3896904a215 (patch)
treedc2044242e735a5c1b89f3daeb66daaaaf53e0a4
parent37890014f406ca2ab24e0ec918af39613642afa0 (diff)
downloadopenembedded-core-contrib-bcbb34c26a235a103b46aa5c8ae7b3896904a215.tar.gz
python-gitdb: add recipe
This is required by python-git. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-gitdb_0.5.4.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-gitdb_0.5.4.bb b/meta/recipes-devtools/python/python-gitdb_0.5.4.bb
new file mode 100644
index 0000000000..9e961528b9
--- /dev/null
+++ b/meta/recipes-devtools/python/python-gitdb_0.5.4.bb
@@ -0,0 +1,18 @@
+SUMMARY = "A pure-Python git object database"
+HOMEPAGE = "http://github.com/gitpython-developers/gitdb"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=59e5ecb13339a936eedf83282eaf4528"
+DEPENDS = "python-async python-smmap"
+
+SRC_URI = "https://pypi.python.org/packages/source/g/gitdb/gitdb-${PV}.tar.gz"
+SRC_URI[md5sum] = "25353bb8d3ea527ba443dd88cd4e8a1c"
+SRC_URI[sha256sum] = "de5d2dac0daec4a9cd7bb1ae1cd42d53510dcf597397c608c12a154b69ad3783"
+
+S = "${WORKDIR}/gitdb-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} += "python-smmap python-async python-mmap python-lang python-zlib python-io python-shell"
+
+BBCLASSEXTEND = "nativesdk"