aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-06-19 14:56:16 +0100
committerSaul Wold <sgw@linux.intel.com>2013-07-02 07:46:03 -0700
commit449ae5a70bc7d7d08f99de7d272b4cc3c83c3dcc (patch)
treee80debb0a73dcfc6cf770281f80942294df7530d
parentbcbb34c26a235a103b46aa5c8ae7b3896904a215 (diff)
downloadopenembedded-core-contrib-449ae5a70bc7d7d08f99de7d272b4cc3c83c3dcc.tar.gz
python-git: add recipe
This is used by buildhistory-diff and the OE layer index, and thus will be useful in the context of the build appliance and buildtools-tarball. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-git_0.3.2.RC1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-git_0.3.2.RC1.bb b/meta/recipes-devtools/python/python-git_0.3.2.RC1.bb
new file mode 100644
index 0000000000..02a0eac040
--- /dev/null
+++ b/meta/recipes-devtools/python/python-git_0.3.2.RC1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Python library used to interact with Git repositories"
+DESCRIPTION = "GitPython provides object model read and write access to \
+a git repository. Access repository information conveniently, alter the \
+index directly, handle remotes, or go down to low-level object database \
+access with big-files support."
+HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
+DEPENDS = "python-gitdb"
+
+SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
+SRC_URI[md5sum] = "849082fe29adc653a3621465213cab96"
+SRC_URI[sha256sum] = "fd6786684a0d0dd7ebb961da754e3312fafe0c8e88f55ceb09858aa0af6094e0"
+
+S = "${WORKDIR}/GitPython-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold"
+
+BBCLASSEXTEND = "nativesdk"