aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-06-19 14:55:06 +0100
committerSaul Wold <sgw@linux.intel.com>2013-07-02 07:46:02 -0700
commit31bc9fa8d53110a09ca048039d83213b34f4b7e4 (patch)
tree857c8603b4f7f5577f0178f9b5bf2a56dc34d693
parentff65497cd9a96d5ab49b16ba1f7e30a216ff4a42 (diff)
downloadopenembedded-core-contrib-31bc9fa8d53110a09ca048039d83213b34f4b7e4.tar.gz
python-async: add recipe
This is required by python-gitdb. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-async_0.6.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-async_0.6.1.bb b/meta/recipes-devtools/python/python-async_0.6.1.bb
new file mode 100644
index 0000000000..17948200e5
--- /dev/null
+++ b/meta/recipes-devtools/python/python-async_0.6.1.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Python framework to process interdependent tasks in a pool of workers"
+HOMEPAGE = "http://github.com/gitpython-developers/async"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e"
+
+SRC_URI = "http://pypi.python.org/packages/source/a/async/async-${PV}.tar.gz"
+SRC_URI[md5sum] = "6f0e2ced1fe85f8410b9bde11be08587"
+SRC_URI[sha256sum] = "41d14cc0456e03f34d13af284f65821d07d05c20e621bcaebd38f9ab5095d5d1"
+
+S = "${WORKDIR}/async-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} += "python-threading python-lang"
+
+BBCLASSEXTEND = "nativesdk"