summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-11-07 15:54:24 +0100
committerSteve Sakoman <steve@sakoman.com>2022-11-21 05:15:12 -1000
commitc893aa4d621de7505fca1bc4b9af22eb503c549c (patch)
tree1874e6cd298d07d4888219cc8130a21d5d6ab9f1
parente0dc0f4a153f75d14d50d5bc91edb93fac93cd25 (diff)
downloadopenembedded-core-contrib-c893aa4d621de7505fca1bc4b9af22eb503c549c.tar.gz
ffmpeg: upgrade 5.1.1 -> 5.1.2
version 5.1.2: - avcodec/dstdec: Check for overflow in build_filter() - avformat/spdifdec: Use 64bit to compute bit rate - avformat/rpl: Use 64bit for duration computation - avformat/xwma: Use av_rescale() for duration computation - avformat/sdsdec: Use av_rescale() to avoid intermediate overflow in duration calculation - avformat/sbgdec: Check ts_int in genrate_intervals - avformat/sbgdec: clamp end_ts - avformat/rmdec: check tag_size - avformat/nutdec: Check fields - avformat/flvdec: Use 64bit for sum_flv_tag_size - avformat/jacosubdec: Fix overflow in get_shift() - avformat/genh: Check nb_channels for IMA ADPCM - avformat/dxa: avoid bpc overflows - avformat/dhav: Use 64bit seek_back - avformat/cafdec: Check that nb_frasmes fits within 64bit - avformat/asfdec_o: Limit packet offset - avformat/apm: Use 64bit for bit_rate computation - avformat/ape: Check frames size - avformat/icodec: Check nb_pal - avformat/aiffdec: Use 64bit for block_duration use - avformat/aiffdec: Check block_duration - avformat/mxfdec: only probe max run in - avformat/mxfdec: Check run_in is within 65536 - avcodec/mjpegdec: Check for unsupported bayer case - avcodec/apedec: Fix integer overflow in filter_3800() - avcodec/tta: Check 24bit scaling for overflow - avcodec/mobiclip: Check quantizer for overflow - avcodec/exr: Check preview psize - avcodec/tiff: Fix loop detection - libavformat/hls: Free keys - avcodec/fmvc: Move frame allocation to a later stage - avfilter/vf_showinfo: remove backspaces - avcodec/speedhq: Check width - avcodec/bink: disallow odd positioned scaled blocks - avformat/cafenc: derive Opus frame size from the relevant stream parameters - avformat/dashdec: Fix crash on invalid input/ENOMEM, fix leak - lavc/videotoolbox: do not pass AVCodecContext to decoder output callback - lavc/pthread_frame: always transfer stashed hwaccel state - avcodec/arm/sbcenc: avoid callee preserved vfp registers - avformat/riffdec: don't unconditionally overwrite WAVEFORMATEXTENSIBLE layout - avfilter/vf_scale: overwrite the width and height expressions with the original values - lavc/pthread_frame: avoid leaving stale hwaccel state in worker threads - avutil/tests/.gitignore: Add channel_layout testtool Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> (cherry picked from commit 32da2113e553a3f81f4dcc5834e3fe30f48e4709) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb (renamed from meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.1.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.1.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb
index 2306fe4a42..a0c98d4ae0 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.1.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_5.1.2.bb
@@ -23,7 +23,7 @@ LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz"
-SRC_URI[sha256sum] = "95bf3ff8c496511e71e958fb249e663c8c9c3de583c5bebc0f5a9745abbc0435"
+SRC_URI[sha256sum] = "619e706d662c8420859832ddc259cd4d4096a48a2ce1eefd052db9e440eef3dc"
# Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717
ARM_INSTRUCTION_SET:armv4 = "arm"