summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-23 13:30:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-26 22:09:25 +0100
commit16c77c82ff6635b0180690ea117e2eff8fd63afb (patch)
treefb0d68dee32b8e872050670590087a26b09e599c
parent71782d90cff825bd9c20d49590245565a6194bf8 (diff)
downloadopenembedded-core-contrib-16c77c82ff6635b0180690ea117e2eff8fd63afb.tar.gz
rust: Skip target recipe since it doesn't work
The target rust recipe is known not to work. Add a SkipRecipe entry for that so world builds don't include something known to be broken and hence give users a sensible message if they do try and build it rather than a build failure. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rust/rust_1.54.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.54.0.bb b/meta/recipes-devtools/rust/rust_1.54.0.bb
index ee60c3e6f1..e7d8d70c26 100644
--- a/meta/recipes-devtools/rust/rust_1.54.0.bb
+++ b/meta/recipes-devtools/rust/rust_1.54.0.bb
@@ -11,3 +11,10 @@ do_compile () {
rust_do_install() {
rust_runx install
}
+
+python () {
+ pn = d.getVar('PN')
+
+ if not pn.endswith("-native"):
+ raise bb.parse.SkipRecipe("Rust recipe doesn't work for target builds at this time. Fixes welcome.")
+}